程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 2015暑假多校聯合---CRB and His Birthday(01背包),2015---crb

2015暑假多校聯合---CRB and His Birthday(01背包),2015---crb

編輯:C++入門知識

2015暑假多校聯合---CRB and His Birthday(01背包),2015---crb


題目鏈接

http://acm.split.hdu.edu.cn/showproblem.php?pid=5410

 

Problem Description Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with M Won(currency unit).
At the shop, there are N kinds of presents.
It costs Wi Won to buy one present of i-th kind. (So it costs k × Wi Won to buy k of them.)
But as the counter of the shop is her friend, the counter will give Ai × x + Bi candies if she buys x(x>0) presents of i-th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤ T ≤ 20
1 ≤ M ≤ 2000
1 ≤ N ≤ 1000
0 ≤ Ai, Bi ≤ 2000
1 ≤ Wi ≤ 2000
  Input There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers M and N.
Then N lines follow, i-th line contains three space separated integers Wi, Ai and Bi.
  Output For each test case, output the maximum candies she can gain.     Sample Input 1 100 2 10 2 1 20 1 1   Sample Output 21   Hint CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.   Author KUT(DPRK)   Source 2015 Multi-University Training Contest 10   Recommend wange2014   題意:輸入M,N,分別表示總的錢數和物品種數,接下來輸入N行,每行3個數,單價、買一件送的糖數 、買一次送的糖數   求最多能得到多少糖?   思路:01背包,dp[i]表示i錢下能得到最多的糖數,vis[i][j]表示i錢下得到最多糖時,是否買j物品,狀態轉移方程dp[i]=dp[i-kind[j][0]]+kind[j][1]+(vis[i-kind[j][0]][j]==0) * kind[j][2];   代碼如下:  
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#define eps 1e-8
#define maxn 105
#define inf 0x3f3f3f3f3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;
int dp[2005];
int vis[2005][1005];
int kind[1005][3];

int main()
{
    int T;
    int M,N;
    cin>>T;
    while(T--)
    {
        scanf("%d%d",&M,&N);
        for(int i=0;i<N;i++)
            scanf("%d%d%d",&kind[i][0],&kind[i][1],&kind[i][2]);
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));

        for(int i=1;i<=M;i++)
        {
            int flag=-1;
            for(int j=0;j<N;j++)
            {
                if(i<kind[j][0]) continue;
                int s=dp[i-kind[j][0]]+kind[j][1];
                if(!vis[i-kind[j][0]][j]) s+=kind[j][2];
                if(dp[i]<s)
                {
                    dp[i]=s;
                    flag=j;
                }
            }
            if(flag>=0)
            {
                for(int j=0;j<N;j++)
                {
                    vis[i][j]=vis[i-kind[flag][0]][j];
                }
                vis[i][flag]++;
            }
        }
        int tmp=0;
        for(int i=1;i<=M;i++)
           tmp=max(tmp,dp[i]);
        printf("%d\n",tmp);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved