程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 3981 字符串替換

POJ 3981 字符串替換

編輯:C++入門知識

一、題目信息
字符串替換
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7501   Accepted: 3560
Description

編寫一個C程序實現將字符串中的所有"you"替換成"we"
Input

輸入包含多行數據

每行數據是一個字符串,長度不超過1000
數據以EOF結束
Output

對於輸入的每一行,輸出替換後的字符串
Sample Input

you are what you do
Sample Output

we are what we do

二、參考代碼

[cpp] 
#include <string>  
#include <iostream> 
using namespace std; 
int main() 

    string str; 
    while(getline(cin,str)) 
    { 
        string::size_type pos = 0; 
        while ( (pos = str.find("you", pos)) != string::npos ) { 
            str.replace( pos++, 3, "we" ); 
        } 
        cout << str << endl; 
    } 
    return 0; 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved