程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDOJ1171 Big Event in HDU

HDOJ1171 Big Event in HDU

編輯:C++入門知識

Big Event in HDU Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 25   Accepted Submission(s) : 8 Problem Description Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).   Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. A test case starting with a negative integer terminates input and this test case is not to be processed.   Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.   Sample Input 2 10 1 20 1 3 10 1  20 2 30 1 -1   Sample Output 20 10 40 40   思路:用多重背包(拆分成01背包)的方法做的,求出0到sum/2裡左右可能的分割方案,然後找出最接近sum/2的。 代碼:

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
struct things{
    int value,num;
}mm[55];
int dp[200000];
int get_max(int a,int b){
    return a>b?a:b;
}
int main(){
    int n,i,j,k,sum,need;
    while(scanf("%d",&n)&&n>0){
        memset(dp,0,sizeof(dp));
        sum=0;
        for(i=1;i<=n;i++){
            scanf("%d%d",&mm[i].value,&mm[i].num);
            sum+=mm[i].value*mm[i].num;
        }
        need=sum/2;
        for(i=1;i<=n;i++)
            for(k=1;k<=mm[i].num;k++)
                for(j=need;j>=mm[i].value;j--)
                    dp[j]=get_max(dp[j],dp[j-mm[i].value]+mm[i].value);
        printf("%d %d\n",sum-dp[need],dp[need]);
    }
    return 0;
}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved