程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1925 Spiderman

POJ 1925 Spiderman

編輯:C++入門知識

Spiderman
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 5692   Accepted: 1107

Description

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web.

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards.

 

\


 

You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.
Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.
Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.
Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4
Sample Output

3
-1
Source

Beijing 2004 Preliminary@POJ
   想著用bfs寫來,結果卻爆棧了,dp的關系其實也知道,還是沒寫出來,把他想麻煩了,第一次發現0x7fffffff+1會越界,真不知以前是怎麼寫,真是沒有注意到這個問題啊

#include <iostream>   
#include <cstring>   
#include <cstdio>   
#include <cmath>   
#define N 5010   
#define M 1000100   
#define INF 0x7ffffff   
using namespace std;  
struct point  
{  
    int x,y;  
}a[N];  
int dp[M];  
int main()  
{  
   // freopen("data1.in","r",stdin);   
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        int n;  
        scanf("%d",&n);  
        for(int i=1;i<=n;i++)  
        {  
            scanf("%d %d",&a[i].x,&a[i].y);  
        }  
        for(int i=0;i<=a[n].x;i++)  
        {  
            dp[i] = INF;  
        }  
        int y1 = a[1].y;  
        dp[a[1].x]=0;  
        for(int i=2;i<=n;i++)  
        {  
            int x2 = a[i].x;  
            int y2 = a[i].y;  
            for(int j=x2-1;j>=a[1].x;j--)  
            {  
                int x1=j;  
                int x = x2 - x1;  
                int y = y2 - y1;  
                __int64 l1 = (__int64)(x)*(__int64)(x)+(__int64)(y)*(__int64)(y);  
                __int64 l2 = (__int64)(y2)*(__int64)(y2);  
                if(l1>l2)  
                {  
                    break;  
                }  
                int k = 2 * x2 - x1;  
                if(k>=a[n].x)  
                {  
                    k = a[n].x;  
                }  
                dp[k] = min(dp[k],dp[x1]+1);  
            }  
        }  
        if(dp[a[n].x]==INF)  
        {  
            printf("-1\n");  
        }else  
        {  
            printf("%d\n",dp[a[n].x]);  
        }  
    }  
    return 0;  
}  

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#define N 5010
#define M 1000100
#define INF 0x7ffffff
using namespace std;
struct point
{
    int x,y;
}a[N];
int dp[M];
int main()
{
   // freopen("data1.in","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&a[i].x,&a[i].y);
        }
        for(int i=0;i<=a[n].x;i++)
        {
            dp[i] = INF;
        }
        int y1 = a[1].y;
        dp[a[1].x]=0;
        for(int i=2;i<=n;i++)
        {
            int x2 = a[i].x;
            int y2 = a[i].y;
            for(int j=x2-1;j>=a[1].x;j--)
            {
                int x1=j;
                int x = x2 - x1;
                int y = y2 - y1;
                __int64 l1 = (__int64)(x)*(__int64)(x)+(__int64)(y)*(__int64)(y);
                __int64 l2 = (__int64)(y2)*(__int64)(y2);
                if(l1>l2)
                {
                    break;
                }
                int k = 2 * x2 - x1;
                if(k>=a[n].x)
                {
                    k = a[n].x;
                }
                dp[k] = min(dp[k],dp[x1]+1);
            }
        }
        if(dp[a[n].x]==INF)
        {
            printf("-1\n");
        }else
        {
            printf("%d\n",dp[a[n].x]);
        }
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved