程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> 問題九十七:Reverse Number

問題九十七:Reverse Number

編輯:關於C語言

[plain]  Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows: 
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21; 
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21; 
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.  
 
Input 
 
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow. 
 
Output 
 
For each test case, you should output its reverse number, one case per line. 
 
Sample Input 
 
 

12 
-12 
1200 
 
Sample Output 
 
 
21 
-21 
2100 

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.

Input

Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

Output

For each test case, you should output its reverse number, one case per line.

Sample Input


3
12
-12
1200

Sample Output


21
-21
2100
[plain]  <PRE class=plain name="code">#include <stdio.h> 
 
int main() 

    int i; 
    int j; 
    int n; 
    int tab;                        //標記末尾是否有零 
    int num; 
    int flag;                      //標記是否是正負數   
    int count; 
    int array[100];                 //存儲各位的數值 
 
    scanf("%d", &n); 
    while(n--) 
    {   
        scanf("%d", &num); 
         
        j=0; 
        tab=1;                //假設末尾有零 
        flag=1;               // 正數為1 
        count=0; 
        if(num<0 ) 
        { 
            flag=0;            //負數 
            num=-1* num;          
        } 
 
        while(num) 
        { 
            if(num%10==0 && tab!=0)     
            { 
               count++;        //計算零的個數 
            } 
            else 
            { 
               array[j++]=num%10; 
               tab=0;      
            } 
            num/=10; 
        } 
 
        if(flag==0)      
        { 
            printf("-"); 
        } 
 
        for(i=0; i<j; i++) 
        { 
             printf("%d", array[i]); 
        } 
         
        for(i=0; i<count; i++)         //打印末尾零的個數 
        { 
            printf("0"); 
        } 
        if(n>0)       
        { 
            printf("\n"); 
        } 
    } 
 
    return 0; 

</PRE><BR> 
<BR> 
<PRE></PRE> 
<P>    </P> 
<PRE></PRE> 
<PRE></PRE> 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved