程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C >> 關於C >> HDU 1250: Hat's Fibonacci

HDU 1250: Hat's Fibonacci

編輯:關於C

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6925 Accepted Submission(s): 2279


Problem Description A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input Each line will contain an integers. Process to end of file.

Output For each case, output the result in a line.
Sample Input
100

Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.



import java.math.BigInteger;     
import java.util.Scanner;     
  
public class Main {     
    
    public static void main(String[] args) {     
        Scanner cin = new Scanner((System.in));     
        int  n;  
        BigInteger[] f = new BigInteger[10000];  
        f[1] = BigInteger.ONE;  
        f[2] = BigInteger.ONE;  
        f[3] = BigInteger.ONE;  
        f[4] = BigInteger.ONE;  
        for(int i=5; i

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved