程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj-1703-Find them, Catch them,poj-1703-findcatch

poj-1703-Find them, Catch them,poj-1703-findcatch

編輯:C++入門知識

poj-1703-Find them, Catch them,poj-1703-findcatch


Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 41928   Accepted: 12886

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

題目大意:判斷倆人是否一個集團,但給的信息是誰和誰不是一個集團的,考的是祖宗節點的距離
題目鏈接:http://poj.org/problem?id=1703

代碼:
#include <iostream>
#include <cstring>
#include <cstdio>
const int MAX=1e5+5;
using namespace std;
int rea[MAX],f[MAX];
int find(int n)
{
    if(n==f[n])
    return n;
    int tmp=f[n];
    f[n]=find(f[n]);
    rea[n]=(rea[tmp]+rea[n])%2;
    return f[n];
}
int main()
{ int t,n,m;
 cin>>t;
while(t--)
{
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        rea[i]=0;
    }
    char a[10];
    int b,c;
    for(int i=0;i<m;i++)
    {
        scanf("%s",a);
        if(a[0]=='D')
        {
            scanf("%d%d",&b,&c);
            int b1=find(b),c1=find(c);
            if(b1!=c1)
            {
                    f[b1]=c1;
                    rea[b1]=(rea[b]+rea[c]+1)%2;
            }
        }
        else
        {
            scanf("%d%d",&b,&c);
            int b1=find(b),c1=find(c);
            if(b1==c1)
            {
                if(rea[b]==rea[c])
               printf("In the same gang.\n");
                else
                printf("In different gangs.\n");

            }
            else
            printf("Not sure yet.\n");
        }
    }



}
    return 0;
}
   
 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved