程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDOJ 1393 Weird Clock(明白題意就簡單了)

HDOJ 1393 Weird Clock(明白題意就簡單了)

編輯:C++入門知識

HDOJ 1393 Weird Clock(明白題意就簡單了)


Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won’t move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin’s type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output “Impossible”.

Sample Input
30 1
0 0

Sample Output
1明白題意之後就簡單了,
思路:一個鐘面只有一根分針。對於一個數字d,把鐘面上的分針指向的時間s往後撥s的d倍。問給定d,重復這樣的操作多少次能回撥到0。若不能則輸出Impossible。
注意:此處的s是不斷更新的!!!!!!!!!!!
因為鐘面只有60分鐘,所以最多不會超過60次,直接暴力就可。
 

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int s= sc.nextInt();
            int d = sc.nextInt();

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int s= sc.nextInt();
            int d = sc.nextInt();
            if(s==0&&d==0){
                return ;
            }
            int num=s;
            for(int i=1;i<65;i++){
                num = (num+(num*d))%60;
                if(num==0){
                    System.out.println(i);
                    break;
                }
                if(i>63){
                    System.out.println("Impossible");
                    break;
                }
            }
        }

    }

}
            if(s==0&&d==0){
                return ;
            }
            int num=s;
            for(int i=1;i<65;i++){
                num = (num+(num*d))%60;
                if(num==0){
                    System.out.println(i);
                    break;
                }
                if(i>63){
                    System.out.println("Impossible");
                    break;
                }
            }
        }

    }

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved