程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 杭電1518,杭電女生遇害

杭電1518,杭電女生遇害

編輯:C++入門知識

杭電1518,杭電女生遇害


HDOJ1518

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11375    Accepted Submission(s): 3660


Problem Description Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?  

 

Input The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.  

 

Output For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".  

 

Sample Input 3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5  

 

Sample Output yes no yes   題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1518  


題意:m根有長度棍子是否能拼成一個正方形 利用DFS和剪枝 在DFS之前首先判斷所有棍子的長度之和是否為4的倍數進行一次剪枝,接著用for循環便利一遍,如果棍子的長度大於正方形的邊長,則不能構成正方形,進行第二次剪枝。 在進行一次排序(由於數據較少,可以省略)。 進行DFS搜索,要標記已經使用了的棍子,一旦不符合要求,就要回溯,並且棍子成為沒有使用的狀態。 DFS的時候要注意優化:   當符合要求的棍子數等於5時,說明已經全部構成正方形的邊長,結束。   每當邊長達到要求是,進入下一根棍子DFS搜索。   還有最重要的一點:每次遍歷一邊棍子不要從0開始,從上一次搜索狀態的下一根棍子開始遍歷,否者會超時。            但是因為數據數目少,我個人感覺也不會要太多時間。可能這用方法是卡著時間過得吧。總之還是自己學的不夠好。   至於這一題的部分思路來源於HDOJ1010 Tempter of the Bone 題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1010


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int s[25];
int sign[25];
int sum;
int ave;
int n;
int flag;
void dfs(int t,int len ,int k)
{
    int i;
    if(t==5)
    {
        flag=1;
        return;
    }
    if(len==ave)
    {
        dfs(t+1,0,0);
        if(flag) return;
    }
    for(i=k; i<n; i++) //從前走到後
        if(sign[i]==0&&s[i]+len<=ave) //標記使用了的棍子
        {
            sign[i]=1;
            dfs(t,s[i]+len,i+1);
            if(flag) return;
            sign[i]=0; //回朔,沒有使用狀態恢復
        }
        else if(sign[i]==0&&s[i]+len>ave) return;
}
int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d",&s[i]);
            sum+=s[i];
        }
        if(sum%4!=0)//構邊的優化
        {
            cout<<"no"<<endl;
            continue;
        }
        ave=sum/4;
        for(i=0; i<n; i++) //有比邊長大的邊就不行
            if(s[i]>ave) break;
        if(i<n)
        {
            cout<<"no"<<endl;
            continue;
        }
        memset(sign,0,sizeof(sign));
        sort(s,s+n);
        flag=0;
        dfs(1,0,0);
        if(flag) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved