程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 周賽C題 LightOJ 1047 (DP),周賽lightoj

周賽C題 LightOJ 1047 (DP),周賽lightoj

編輯:C++入門知識

周賽C題 LightOJ 1047 (DP),周賽lightoj


C - C Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu  

Description

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and Bare the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

 

4

13 23 12

77 36 64

44 89 76

31 78 45

 

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

Hint

Use simple DP

 

題解:   有n家人,要把他們的房子塗上顏色,有紅、綠、藍三種顏色,每家塗不同的顏色要花不同的費用,而且相鄰兩戶人家之間的顏色要不同,求最小的總花費費用。

     看案例可以從第一行往下模擬,然後就知道了怎麼去實現,還是動態規劃,求最小的值,有限制條件,每次走到點和上次走的點不在同一列。

代碼:

#include<iostream>
#include<cstdio>
using namespace std;
int dp[1005][1005];
int a[1005][1005];
int main()
{
    int T,n,k=1;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=3; j++)
                cin>>a[i][j];
        for(int i=1; i<=n; i++)
            for(int j=1; j<=3; j++)
            {
                dp[i][j%3+1]=min(dp[i-1][(j-1)%3+1],dp[i-1][(j+1)%3+1])+a[i][j%3+1];           // 相當於滾筒數組,優化
            }
        int total=min(dp[n][1],min(dp[n][2],dp[n][3]));
        cout<<"Case "<<k++<<": "<<total<<endl;
    }
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved