程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UvaLive 6661 Equal Sum Sets (DFS),uvalive6661

UvaLive 6661 Equal Sum Sets (DFS),uvalive6661

編輯:C++入門知識

UvaLive 6661 Equal Sum Sets (DFS),uvalive6661


 

 

Let us consider sets of positive integers less than or equal to n. Note that all elements of a set are different. Also note that the order of elements doesnt matter, that is, both {3, 5, 9} and {5, 9, 3} mean the same set.

Specifying the number of set elements and their sum to be k and s, respectively, sets satisfying the conditions are limited. When n = 9, k = 3 and s = 23, {6, 8, 9} is the only such set. There may be more than one such set, in general, however. When n = 9, k = 3 and s = 22, both {5, 8, 9} and {6, 7, 9} are possible.

You have to write a program that calculates the number of the sets that satisfy the given conditions.

Input

The input consists of multiple datasets. The number of datasets does not exceed 100. Each of the datasets has three integers n, k and s in one line, separated by a space. You may assume 1 ≤ n ≤ 20, 1 ≤ k ≤ 10 and 1 ≤ s ≤ 155. The end of the input is indicated by a line containing three zeros.

Output The output for each dataset should be a line containing a single integer that gives the number of the sets that satisfy the conditions. No other characters should appear in the output. You can assume that the number of sets does not exceed 231 − 1.

Sample Input

9 3 23

9 3 22

10 3 28

16 10 107

20 8 102

20 10 105

20 10 155

3 4 3

4 2 11

0 0 0

Sample Output

1

2

0

20

1542

5448

1

0

0

 

 

題意:

求從不超過 N 的正整數當中選取 K 個不同的數字,組成和為 S 的方法數。

1 <= N <= 20  1 <= K<= 10  1 <= S <= 155

 

AC代碼

#include<iostream>
using namespace std;
int n,k,s,total;
void dfs(int x,int y,int z)
{
    if(y==k&&z==s)
    {
        total++;
        return;
    }
    for(int i=1; i<=x-1; i++)
    {
        if(z+i<=s)
        dfs(i,y+1,z+i);
    }
}
int main()
{
    while(cin>>n>>k>>s&&n&&k&&s)
    {
        total=0;
        dfs(n+1,0,0);
        cout<<total<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved