程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1372:Knight Moves(經典BFS題),hdu1372bfs

HDU1372:Knight Moves(經典BFS題),hdu1372bfs

編輯:C++入門知識

HDU1372:Knight Moves(經典BFS題),hdu1372bfs


                                          HDU1372:Knight Moves(BFS)

  Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu  

Description

 

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

 

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

 

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

 

Sample Input

 

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

 

Sample Output

 

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

題解:騎士走日,和中國象棋中的馬一樣走日。

  廣搜bfs就可以

AC代碼:

#include <iostream>
#include <queue>
#include<string.h>
using namespace std;
int s1,s2,e1,e2;
int tu[8][8];
int xx[8] = {1, 2, 1, 2, -1, -2, -1, -2};//x坐標變化
int yy[8] = {2, 1, -2, -1, 2, 1, -2, -1};//y坐標變化
int bfs()
{
    memset(tu,0,sizeof(tu));//數組值全為0
    queue<int> q;
    int x1,y1,x2,y2;
    tu[s1][s2]=0;//
    q.push(s1);
    q.push(s2);
    while(!q.empty())
    {
        x1=q.front();
        q.pop();
        y1=q.front();
        q.pop();
        if(x1==e1&&y1==e2)//在原地不動
            return tu[x1][y1];
        for(int i=0; i<8; i++)
        {
            x2=x1+xx[i];
            y2=y1+yy[i];
            if(x2<0||x2>7||y2<0||y2>7||tu[x2][y2]>0)
                continue;
            tu[x2][y2]=tu[x1][y1]+1;
            q.push(x2);
            q.push(y2);
        }
    }
    return 0;
}
int main()
{
    char a[3],b[3];
    int total;
    while(cin>>a>>b)
    {
        s1=a[0]-'a';//輸入的字母,是列,從第一列a開始,減去'a',轉換
        s2=a[1]-'1';//輸入的數字,是行,從的第一行開始,減去'1',轉換
        e1=b[0]-'a';
        e2=b[1]-'1';
        total=bfs();
        cout<<"To get from "<<a<<" to "<<b<<" takes "<<total<<" knight moves."<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved