程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU-1013-Digital Roots(Java && 大數 && 數根)

HDU-1013-Digital Roots(Java && 大數 && 數根)

編輯:C++入門知識

HDU-1013-Digital Roots(Java && 大數 && 數根)


Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57047 Accepted Submission(s): 17799



Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3

Source Greater New York 2000
Recommend We have carefully selected several similar problems for you: 1017 1021 1012 1018 1048
解釋一下題目: 就是給你一個數讓你求數的樹根!什麼叫樹根? 比如24這個數的樹根,就是把24各個位的數加起來!2+4=6 而且6是個位數,於是它就是24的樹根。 然後39這個數一樣的方法,3+9=12 此時我們發現12不是個位數,所以它不是數根,繼續讓它各個 位數相加,1+2=3,3是個位數所以3是39的數根。
數根公式: a的數根b = ( a - 1) % 9 + 1 還不明白可以百度百科一下數根,很簡單的數學定義,簡稱自然數的一種定義.
import java.io.*;
import java.math.BigInteger;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		while (input.hasNext())
		{
			String num = input.next();
			if (num.equals("0"))
				break;
			BigInteger bigInteger = new BigInteger(num);
			BigInteger Nine = new BigInteger("9");
			BigInteger MinusOne = new BigInteger("-1");
			BigInteger b = bigInteger.add(MinusOne);
			b = b.mod(Nine);
			b = b.add(BigInteger.ONE);
			System.out.println(b);
		}
	}

}


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved