程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 3268 Silver Cow Party (最短路)

poj 3268 Silver Cow Party (最短路)

編輯:C++入門知識

poj 3268 Silver Cow Party (最短路)


Silver Cow Party Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 12913 Accepted: 5778

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


題目是讓求所有點到目標地點的最短路中的最大值。

思路:用兩個二維數組分別存邊的信息,兩次dijkstra求得最短路。也可以用spfa求,速度很慢。

#include"stdio.h"
#include"string.h"
#define N 1005
const int inf=0x7fffffff;
int n,m,x;
int g1[N][N],g2[N][N];
int dis1[N],dis2[N],mark[N];
void dijkstra(int g[N][N],int *dis)
{
    int i,u,min;
    for(i=1;i<=n;i++)
    {
        dis[i]=inf;
        mark[i]=0;
    }
    dis[x]=0;
    while(1)
    {
        u=0;
        min=inf;
        for(i=1;i<=n;i++)
        {
            if(min>dis[i]&&!mark[i])
            {
                min=dis[i];
                u=i;
            }
        }
        if(u==0)
            break;
        mark[u]=1;
        for(i=1;i<=n;i++)
        {
            if(g[u][i]dis[u]+g[u][i])
                dis[i]=dis[u]+g[u][i];
        }
    }
}
int main()
{
    int i,j,u,v,w;
    while(scanf("%d%d%d",&n,&m,&x)!=-1)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
                g1[i][j]=g2[i][j]=inf;
        }
        for(i=0;it?ans:t;
        }
        printf("%d\n",ans);
    }
    return 0;
}





  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved