程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1029 map做法

hdu 1029 map做法

編輯:C++入門知識

Ignatius and the Princess IV
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 9654    Accepted Submission(s): 3785


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
 

Sample Output
3
5
1
 
題意:輸入n個數  n為奇數  問某個數出現的次數大於等於(N+1)/2的是 哪個  輸出來
 
思路  map記錄
 
[cpp] 
#include<stdio.h> 
#include<map> 
#include<iostream> 
using namespace std; 
map<int,int>mp; 
int main() 

    int i,j,n,N; 
    while(scanf("%d",&n)!=EOF) 
    { 
        N=n; 
        mp.clear(); 
        while(n--) 
        { 
        scanf("%d",&i); 
        mp[i]++; 
        } 
        map<int,int>::iterator it; 
        printf("cc"); 
        for(it=mp.begin();it!=mp.end();i++) 
        { 
            if(it->second>=(N+1)/2) {printf("%d\n",it->first);break;} 
        } 
    } 
    return 0; 
 

 
 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved