程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 4310 Hero

hdu 4310 Hero

編輯:C++入門知識

Problem A
Time Limit : 6000/3000ms (Java/Other) Memory Limit : 65536/65536K (Java/Other)

Total Submission(s) : 12 Accepted Submission(s) : 9

Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
Output
Output one line for each test, indicates the minimum HP loss.
Sample Input
1
10 2
2
100 1
1 100
Sample Output
20
201
 
題意:有n組敵人,每次攻擊一個敵人會使這個敵人的HP減1,但是同時我的DPS(開始是是無窮的)的值會減少所有沒消滅的敵人的DPS總和,要求將所有的敵人都消滅後我的DPS剩余的最多,即求耗費的DPS的值最少。


分析:用貪心,將所有的敵人根據DPS/HP從大到小排序,如果相等,則按HP從小到大排序

代碼:

[cpp] 
<span style="font-family:FangSong_GB2312;font-size:18px;">#include<iostream> 
#include<cmath> 
#include<algorithm>  
using namespace std; 
struct node 

       int x,y; 
}a[25]; 
int cmp(node a,node b) 

    if(1.0*a.y/a.x==1.0*b.y/b.x) 
      return a.x<b.x; 
     else return  1.0*a.y/a.x>1.0*b.y/b.x;      

int main() 

    int n,i,j,sum,cnt; 
   while(scanf("%d",&n)!=EOF) 
   { 
     sum=cnt=0; 
    for(i=0;i<n;i++) 
    { 
      scanf("%d%d",&a[i].x,&a[i].y); 
      sum+=a[i].y; 
    } 
    sort(a,a+n,cmp); 
    for(i=0;i<n;i++) 
    { 
      cnt+=sum*a[i].x; 
      sum=sum-a[i].y; 
    } 
    printf("%d\n",cnt); 
  } 
  return 0; 
}  
</span> 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved