程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2473 Junk-Mail Filter [並查集+設立虛父節點(馬甲)]

HDU 2473 Junk-Mail Filter [並查集+設立虛父節點(馬甲)]

編輯:C++入門知識

原題:
Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0
 

Sample Output
Case #1: 3
Case #2: 2
 

分析與總結:
有N封郵件, 然後又兩種操作,如果是M X Y , 表示X和Y是相同的郵件。 如果是S X,那麼表示對X的判斷是錯誤的,X是不屬於X當前所在的那個集合,要把X分離出來,讓X變成單獨的一個。

很明顯是用並查集來做。 開始讓我混淆的一個地方是,假設如下情況
M 0 2
M 1 2
S  2
那麼按照並查集來做, 0指向2, 1指向2,即
0 -->2
1 -->2 ,
那麼刪除2之後,我以為題目意思是所有與2有關系的都要刪除, 那麼這兩個關系都要去掉, 又變成獨立的3個了。
但是我這種理解是錯的。 合並起來後就是一個集合{0,1,2},  如果把2刪除掉之後, {0,1}還是集合。

理解題意之後, 我們知道用並查集來構造集合是很容易的,但是要把集合中的一個刪掉,卻很不容易。 通過這題,我學習到了所謂的設立需父節點的方法。
關鍵的過程是假設要刪除x點, 那麼不是真的刪除x點, 而是通過一個映射(這裡用數組majia[N]),把x變成一個新的點即majia[x] = newNode.那麼, 原來的那些集合還是不變,只是少了個x點。


代碼:
[cpp] 
#include<cstdio> 
#include<cstring> 
#define N 1100000 
int f[N],rank[N],majia[N],flag[N],id,n,m; 
 
inline void init(){ 
    for(int i=0; i<n; ++i) 
        f[i]=majia[i]=i; 
    memset(rank, 0, sizeof(rank)); 
    id=n; 

int find(int x){ 
    int i, j=x; 
    while(j!=f[j]) j=f[j]; 
    while(x!=j){i=f[x];f[x]=j;x=i;} 
    return j; 

void Union(int x,int y){ 
    int a=find(x), b=find(y); 
    if(a==b)return ; 
    if(rank[a]>rank[b]) 
        f[b]=a; 
    else{ 
        if(rank[a]==rank[b]) 
            ++rank[b]; 
        f[a]=b; 
    } 

void Delete(int x){ 
    f[id]=id;    
    majia[x]=id++; 

 
 
int main(){ 
    char cmd[3]; 
    int a,b,cas=1; 
    while(~scanf("%d%d",&n,&m)&&n+m){ 
        init(); 
        for(int i=0; i<m; ++i){ 
            scanf("%s",cmd); 
            if(cmd[0]=='M'){ 
                scanf("%d%d",&a,&b); 
                Union(majia[a],majia[b]); 
            } 
            else{ 
                scanf("%d",&a); 
                Delete(a); 
            } 
        } 
        memset(flag, 0, sizeof(flag)); 
        int ans=0; 
        for(int i=0; i<n; ++i){ 
            a=find(majia[i]); 
            if(!flag[a]){ 
                ++ans; 
                flag[a]=1; 
            } 
        } 
        printf("Case #%d: %d\n",cas++, ans); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved