程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj3537 Crosses and Crosses----sg

poj3537 Crosses and Crosses----sg

編輯:C++入門知識

Crosses and Crosses
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 1866   Accepted: 687
Case Time Limit: 2000MS
Description
The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.
You are given n. Find out who wins if both players play optimally.
Input
Input file contains one integer number n (3 ≤ n ≤ 2000).
Output
Output ‘1’ if the first player wins, or ‘2’ if the second player does.
Sample Input
#1 3
#2 6
Sample Output
#1 1
#2 2
Source
Northeastern Europe 2007, Northern Subregion
 
在第I個位置放一個X,即可分為兩個子游戲,I-3和n-I-2
 
[cpp] 
#include<iostream> 
#include<cstdlib> 
#include<stdio.h> 
#include<memory.h> 
using namespace std; 
int sg[2100]; 
int dfs(int n) 

    if(n<0) return 0;//n<0 
    if(sg[n]>=0) return sg[n]; 
    bool g[2001]={0}; 
    for(int i=1;i<=n;i++) 
    { 
        int t=dfs(i-3)^dfs(n-i-2); 
        g[t]=1; 
    } 
    for(int i=0;;i++) 
    if(g[i]==0) return sg[n]=i; 

int main() 

    memset(sg,-1,sizeof(sg)); 
    int n; 
    while(scanf("%d",&n)!=EOF) 
    { 
        if(dfs(n)) puts("1"); 
        else puts("2"); 
    } 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved