程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 廣搜1 poj 2243

廣搜1 poj 2243

編輯:C++入門知識

Knight Moves
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8800   Accepted: 5051
Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".
Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
大家注意這題騎士移動就像中國象棋馬一樣走“日”型,枚舉每個點要走的8個方向,最先到達重點的那個步數最少。輸出之。。。
Accepted 696K 47MS G++
poj  2243:
代碼:

#include <iostream>

#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=15;
int n,m,ans;
bool vis[maxn][maxn];
int dir[8][2]= {{-1,-2},{1,-2},{-1,2},{1,2},{-2,1},{-2,-1},{2,-1},{2,1}};
struct  data
{
    int x,y,step;
}node[maxn*maxn];
int ex,ey;
int bfs(int x,int y)
{
int l=0,r=0;
node[r].x=x;node[r].y=y;
node[r++].step=0;


vis[x][y]=1;
if(x==ex&&y==ey)
return 0;
while(l<r)
{
  data next,a;
  a.x=node[l].x;
  a.y=node[l].y;
  a.step=node[l++].step;
for(int i=0; i<8; i++)
{
next.x=a.x+dir[i][0];
next.y=a.y+dir[i][1];
next.step=a.step+1;
if(next.x>=1&&next.x<=8&&next.y>=1&&next.y<=8&&!vis[next.x][next.y])
{
if(next.x==ex&&next.y==ey)
{
    return next.step;
}
vis[next.x][next.y]=1;
node[r].x=next.x,node[r].y=next.y;
node[r++].step=next.step;
}
}
}
return -1;
}
int main()
{
    char s1[3],s2[3];
while(scanf("%s%s",s1,s2)!=EOF)
{
int sx,sy;
sx=s1[0]-'a'+1;sy=s1[1]-'0';
ex=s2[0]-'a'+1;ey=s2[1]-'0';
memset(vis,0,sizeof(vis));
ans=bfs(sx,sy);
printf("To get from %s to %s takes %d knight moves.\n",s1,s2,ans);
}
return 0;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved