程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 1546 Idiomatic Phrases Game

HDU 1546 Idiomatic Phrases Game

編輯:C++入門知識

題目:
Idiomatic Phrases Game
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 969    Accepted Submission(s): 300


Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
 

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
 

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 

Sample Input
5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0
 

Sample Output
17
-1
 


題目大意:
給出n個“成語”, 這寫成語至少由3個“漢字”組成,所謂的“漢字”,是指4個連續的16進制數字(1~9, A~F)。
以第一個成語作為起點,最後一個作為終點, 需要找出一個序列,這個序列的前一個成語的最後一個“漢字”與後一個成語的第一個“漢字”是相同的,求最少花費時間。

分析與總結:
建好圖之後就是最基本的最短路問題。
在輸入時,對於每個成語只需要保存第一個漢字與最後一個漢字即可。


代碼:
[cpp]
#include<iostream> 
#include<cstdio> 
#include<cstring> 
#include<queue> 
#include<utility> 
using namespace std; 
 
typedef pair<int,int>pii; 
priority_queue<pii,vector<pii>,greater<pii> >q; 
 
const int INF = 0x7fffffff; 
const int VN  = 1005; 
 
struct Edge{int v,next,w;}E[VN*VN]; 
struct Idiom{ 
    char beg[5], end[5]; 
}arr[VN]; 
 
int n,size; 
int head[VN]; 
int d[VN]; 
int cost[VN]; 
 
void init(){ 
    size=0; 
    memset(head, -1, sizeof(head)); 
    while(!q.empty())q.pop(); 

void addEdge(int u,int v,int w){ 
    E[size].v=v, E[size].w=w; 
    E[size].next = head[u]; 
    head[u] = size++; 

 
void Dijkstra(int src){ 
    for(int i=1; i<=n; ++i) d[i] = INF; 
    d[src] = 0; 
    q.push(make_pair(d[src],src)); 
    while(!q.empty()){ 
        pii x = q.top(); q.pop(); 
        int u = x.second; 
        if(d[u] != x.first) continue; 
        for(int e=head[u]; e!=-1; e=E[e].next){ 
            int tmp = d[u] + E[e].w; 
            if(d[E[e].v] > tmp){ 
                d[E[e].v] = tmp; 
                q.push(make_pair(tmp, E[e].v)); 
            } 
        } 
    } 

 
int main(){ 
    int w; 
    char str[100]; 
    while(scanf("%d",&n)&&n){ 
        init(); 
        for(int i=1; i<=n; ++i){ 
            scanf("%d %s",&cost[i],str); 
            for(int j=0; j<5; ++j)  
                arr[i].beg[j]=str[j]; 
            int len = strlen(str); 
            for(int j=len-4,k=0; j<len; ++j,++k)  
                arr[i].end[k]=str[j]; 
            arr[i].end[4] = arr[i].beg[4] = 0; 
        } 
        for(int i=1; i<n; ++i){ 
            for(int j=1; j<=n; ++j){ 
                if(strcmp(arr[i].end, arr[j].beg)==0) 
                    addEdge(i,j,cost[i]);  
            } 
        } 
        Dijkstra(1); 
        if(d[n]!=INF) printf("%d\n", d[n]); 
        else  puts("-1"); 
    } 
    return 0; 


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved