程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 杭電OJ——1036 Average is not Fast Enough!

杭電OJ——1036 Average is not Fast Enough!

編輯:C++入門知識

Average is not Fast Enough!

 

Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
 

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
 

Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
 

Sample Input
2 12.5
  5 0:23:21 0:25:01
 42 0:23:32 -:--:--
  7 0:33:20 0:41:35
 

Sample Output
  5: 3:52 min/km
 42: -
  7: 6:00 min/km
 
題目意思我看了半天才看懂!看來要好好學英語了!
代碼如下:
[cpp] 
//這個程序雖然比較小,但是包含的各種技能還是很多的! 
/*
#include<stdio.h>
#include<iostream>
using namespace std;
 
int main()
{
    int n,sumtime,num;
    double d;
    char h,m1,m2,s1,s2;
    scanf("%d",&n);
    scanf("%lf",&d);
    while(scanf("%d",&num)!=EOF)//題目意思是對於每個隊伍便輸出答案
    {
        printf("%3d ",num);
        bool flag=true;
        sumtime=0;
        for(int i=0;i<n;i++)
        {
            getchar();
            scanf("%c:%c%c:%c%c",&h,&m1,&m2,&s1,&s2);
            if(h=='-') flag=false;
            if(flag==false) continue;//這裡如果輸入了"-:--:--",那麼接下來就不用計算了!
            sumtime=sumtime+(h-'0')*3600+((m1-'0')*10+(m2-'0'))*60+(s1-'0')*10+s2-'0';
        }
        //cout<<sumtime<<endl;//這裡計算總時間是正確的!
        
        if(flag)
        {
            int t2=sumtime/d+0.5;//這裡算出來了平均每走一千米所需要的時間(s),這裡由於數據的緣故需要四捨五入!
            //cout<<"t2="<<t2<<endl;
            if(t2-t2/60*60<10)
            printf("%d:0%d min/km\n",t2/60,t2-t2/60*60);
            else
            printf("%d:%d min/km\n",t2/60,t2-t2/60*60);
        }
        else
            printf("-\n");
 
    }
    return 0;
}
*/ 
//我想要測試一下所遇到的一些問題! 
 
#include<stdio.h> 
 
int main() 

    int num; 
    while(scanf("%d",&num)!=EOF)//測試結果表明:無論之前輸入多少個空格都不會被記入num,一次輸入多個num的值,這些值會被入棧!然後再執行!這和之前課程設計時遇到的情況是一樣的! 
    { 
        printf("%d\n",num); 
    } 
    return 0; 

//還有一點關於AC題的,那就是輸入和答案是分開的,AC的只檢測答案! 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved