程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 3276 反轉開燈問題 每次選取連續k個反轉方向 問多少次方向相同

POJ 3276 反轉開燈問題 每次選取連續k個反轉方向 問多少次方向相同

編輯:C++入門知識

Face The Right Way
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 1833   Accepted: 860

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.
Output

Line 1: Two space-separated integers: K and M
Sample Input

7
B
B
F
B
F
B
BSample Output

3 3Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)
Source

USACO 2007 March Gold
 
題意:
N個牛  每個都有一定的方向 B背對 F表示頭對著你  給你一個裝置   每次可以選擇連續的K個牛反轉方向  問你如何選擇K  使得操作數最少    k也應盡量小

//思路:  從第一個開始找如果當前為B 就需要改變 改變i到i+k-1的位置
//一直找到n-k+1處 之後判斷從n-k+2到n是否滿足了題意  注意不要真的去修改
//用一個sum值標記前面k-1個修改了多少次用來決定當前的是否要修改 利用尺取法 即前後推進
#include<stdio.h>
#include<string.h>
int a[5100],n,flag[5100];
int solve(int k)
{
    int i;
    memset(flag,0,sizeof(flag));//flag[i]表示區間[i,i+k-1] 是否需要翻轉
    int sum=0,cnt=0;//前k-1個轉變的次數
    for(i=1;i<=n-k+1;i++)//sum記錄走到當前i,其前面k-1個翻轉了多少次
    {
        if(i-k>=1)
        {
            sum-=flag[i-k];
        }
        if(a[i]==0&&sum%2==0)//如果是B 且前面翻轉了偶數次 仍舊需要翻轉
        {
             flag[i]=1;
             sum+=flag[i];
             cnt++;
        }
        else if(a[i]==1&&sum%2==1)//如果是F  且前面翻轉了奇數次
        {
            flag[i]=1;
            sum+=flag[i];
            cnt++;
        }

       // printf("i=%d flag[i]=%d\n",i,flag[i]);
    }

        for(i;i<=n;i++)
        {
           if(i-k>=1)
           {
              sum-=flag[i-k];
           }
           if(sum%2==0&&a[i]==0) return -1;
           else if(sum%2==1&&a[i]==1) return -1;
        }
        return cnt;


}
int main()
{
    int i,k,mn;
    char s[2];
    while(scanf("%d",&n)!=EOF)
    {
        mn=100010000;
        for(i=1;i<=n;i++)
        {
            scanf("%s",s);
            if(s[0]=='B') a[i]=0;
            else if(s[0]=='F') a[i]=1;

        }
        k=1;
        for(i=1;i<=n;i++)
            {
                int mid=solve(i);
                //printf("k=%d,cnt=%d\n",i,mid);
                if(mid==-1) continue;
                if(mn>mid) {mn=mid;k=i;}
            }
        printf("%d %d\n",k,mn);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved