程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1856:More is better

HDU1856:More is better

編輯:C++入門知識

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 


Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 


Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
  
 

//因為要找最大的,所以用num來記載所有情況,在比較找出最大的


 

[cpp]
#include <stdio.h>  
 
struct A 

    int num; 
    int pre; 
} set[10000005]; 
 
void bulid(int n) 

    int i; 
    for(i = 1; i<=n; i++) 
    { 
        set[i].pre = i; 
        set[i].num = 1; 
    } 

 
int find(int x) 

    if(set[x].pre == x) 
        return x; 
    return set[x].pre = find(set[x].pre); 

 
void Union(int x,int y) 

    set[x].pre = y; 
    set[y].num+=set[x].num; 

 
int main() 

    int big,n,f1,f2,i; 
    int x[100005],y[100005]; 
    while(~scanf("%d",&n)) 
    { 
        big = 0; 
        int ans = 0; 
        if(n==0) 
        { 
            printf("1\n"); 
            continue; 
        } 
        for(i = 1; i<=n; i++) 
        { 
            scanf("%d%d",&x[i],&y[i]); 
            if(x[i]>big) big = x[i]; 
            if(y[i]> big) big = y[i]; 
        } 
        bulid(big); 
        for(i = 1; i<=n; i++) 
        { 
            f1 = find(x[i]); 
            f2 = find(y[i]); 
            if(f1!=f2) 
                Union(f1,f2); 
        } 
        for(i = 1; i<=big; i++) 
        { 
            if(set[i].num > ans) 
                ans = set[i].num; 
        } 
        printf("%d\n",ans); 
    } 
 
    return 0; 

#include <stdio.h>

struct A
{
    int num;
    int pre;
} set[10000005];

void bulid(int n)
{
    int i;
    for(i = 1; i<=n; i++)
    {
        set[i].pre = i;
        set[i].num = 1;
    }
}

int find(int x)
{
    if(set[x].pre == x)
        return x;
    return set[x].pre = find(set[x].pre);
}

void Union(int x,int y)
{
    set[x].pre = y;
    set[y].num+=set[x].num;
}

int main()
{
    int big,n,f1,f2,i;
    int x[100005],y[100005];
    while(~scanf("%d",&n))
    {
        big = 0;
        int ans = 0;
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        for(i = 1; i<=n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            if(x[i]>big) big = x[i];
            if(y[i]> big) big = y[i];
        }
        bulid(big);
        for(i = 1; i<=n; i++)
        {
            f1 = find(x[i]);
            f2 = find(y[i]);
            if(f1!=f2)
                Union(f1,f2);
        }
        for(i = 1; i<=big; i++)
        {
            if(set[i].num > ans)
                ans = set[i].num;
        }
        printf("%d\n",ans);
    }

    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved