程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1326:Box of Bricks

HDU1326:Box of Bricks

編輯:C++入門知識

Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

 

 

 


Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

 


Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

 


Sample Input
6
5 2 4 1 7 5
0


Sample Output
Set #1
The minimum number of moves is 5.

 

我的思路很簡單,首先排序,然後如下處理

 

[cpp]
#include <stdio.h>  
#include <algorithm>  
using namespace std; 
 
int main() 

    int n,cas = 1; 
    while(~scanf("%d",&n),n) 
    { 
        int a[100],i,sub = 0; 
        for(i = 0;i<n;i++) 
        { 
            scanf("%d",&a[i]); 
            sub+=a[i]; 
        } 
        sub = sub/n; 
        sort(a,a+n); 
        int sum = 0; 
        printf("Set #%d\nThe minimum number of moves is ",cas++); 
        while(a[n-1]>sub) 
        { 
            if(a[n-1]-sub>sub - a[0])//最大的達到平均值時多出的比最小的欠缺的多,把小的補滿,大的統計剩余的  
            { 
                sum+=sub-a[0]; 
                a[n-1] = a[n-1] - (sub-a[0]); 
            } 
            else if(a[n-1]-sub == sub - a[0])//相等則兩兩補滿  
            { 
                sum+=a[n-1]-sub; 
                a[n-1] = sub; 
                a[0] = sub; 
            } 
            else//小於,則先把最大的變成平均,多出的移到最少  
            { 
                sum += a[n-1] - sub; 
                a[n-1] = sub; 
                a[0] = a[0] + a[n-1] - sub; 
            } 
            sort(a,a+n);//每次都排序一次  
        } 
        printf("%d.\n\n",sum); 
    } 
 
    return 0; 

#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
    int n,cas = 1;
    while(~scanf("%d",&n),n)
    {
        int a[100],i,sub = 0;
        for(i = 0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sub+=a[i];
        }
        sub = sub/n;
        sort(a,a+n);
        int sum = 0;
        printf("Set #%d\nThe minimum number of moves is ",cas++);
        while(a[n-1]>sub)
        {
            if(a[n-1]-sub>sub - a[0])//最大的達到平均值時多出的比最小的欠缺的多,把小的補滿,大的統計剩余的
            {
                sum+=sub-a[0];
                a[n-1] = a[n-1] - (sub-a[0]);
            }
            else if(a[n-1]-sub == sub - a[0])//相等則兩兩補滿
            {
                sum+=a[n-1]-sub;
                a[n-1] = sub;
                a[0] = sub;
            }
            else//小於,則先把最大的變成平均,多出的移到最少
            {
                sum += a[n-1] - sub;
                a[n-1] = sub;
                a[0] = a[0] + a[n-1] - sub;
            }
            sort(a,a+n);//每次都排序一次
        }
        printf("%d.\n\n",sum);
    }

    return 0;
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved