程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1718:Rank

HDU1718:Rank

編輯:C++入門知識

Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.

 


Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.

 


Output
For each test case, output a line giving Jackson’s rank in the class.
 


Sample Input
20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0


Sample Output
2

 

只需要找出成績比本人成績高的個數再加1就可以了

[cpp]
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std; 
int cmp(const int x,const int y) 

    return x > y; 

int main() 

    char flag[100],a[100]; 
    int k,b,tem,num[1005]; 
    while(~scanf("%s",flag)) 
    { 
        k = 0; 
        while(~scanf("%s%d",&a,&b)) 
        { 
            if(!strcmp(a,"0") && b==0) break; 
            if(!strcmp(a,flag)) 
                tem = b; 
            num[k++] = b; 
        } 
        sort(num,num+k,cmp); 
        int cnt = 1; 
        for(int i = 0; i<k; i++) 
        { 
            if(num[i] > tem) 
                cnt++; 
            else 
                break; 
        } 
        printf("%d\n",cnt); 
    } 
    return 0; 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int cmp(const int x,const int y)
{
    return x > y;
}
int main()
{
    char flag[100],a[100];
    int k,b,tem,num[1005];
    while(~scanf("%s",flag))
    {
        k = 0;
        while(~scanf("%s%d",&a,&b))
        {
            if(!strcmp(a,"0") && b==0) break;
            if(!strcmp(a,flag))
                tem = b;
            num[k++] = b;
        }
        sort(num,num+k,cmp);
        int cnt = 1;
        for(int i = 0; i<k; i++)
        {
            if(num[i] > tem)
                cnt++;
            else
                break;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved