程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1165:Eddys research II

HDU1165:Eddys research II

編輯:C++入門知識

Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

 


Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.

 


Output
For each value of m,n, print out the value of A(m,n).

 


Sample Input
1 3
2 4


Sample Output
5
11

 

 

一道規律題

可以先寫函數一個個數字打印出來,然後找規律

規律在代碼中可見

 

[cpp]
#include <stdio.h>  
 
int main() 

    int n,m; 
    __int64 a[30]; 
    int i; 
    a[0] = 5; 
    for(i = 1; i<=24; i++) 
    { 
        a[i] = 2*a[i-1]+3; 
    } 
    while(~scanf("%d%d",&m,&n)) 
    { 
        if(m == 1) 
            printf("%d\n",2+n); 
        else if(m == 2) 
            printf("%d\n",3+2*n); 
        else if(m == 3) 
        printf("%I64d\n",a[n]); 
        } 
 
    return 0; 

#include <stdio.h>

int main()
{
    int n,m;
    __int64 a[30];
    int i;
    a[0] = 5;
    for(i = 1; i<=24; i++)
    {
        a[i] = 2*a[i-1]+3;
    }
    while(~scanf("%d%d",&m,&n))
    {
        if(m == 1)
            printf("%d\n",2+n);
        else if(m == 2)
            printf("%d\n",3+2*n);
        else if(m == 3)
        printf("%I64d\n",a[n]);
        }

    return 0;
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved