程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 2418 Hardwood Species 二叉排序樹

POJ 2418 Hardwood Species 二叉排序樹

編輯:C++入門知識

Hardwood Species
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 15011   Accepted: 6042


Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.
Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.
Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.
Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow
Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

 

 

 


二叉排序樹,和其他正常一樣,左大右小,排完中序輸出就可以了。。。

本來還考慮用sort排序,然後計算下數就行了,可是題目說10000結點1000000樹,果斷會超時,即使題目給10s也不夠啊。。。

果斷要用二叉樹,在建樹時還能計算出現次數。。。

Accepted 564K 1469MS G++ 954B
 


AC代碼:


[cpp]
#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#define MAXN 40  
 
typedef struct TNode{ 
    char name[MAXN]; 
    struct TNode *l, *r; 
    int cnt; 
}Node; 
int sum = 0; 
 
Node* newnd(char *ch) 

    Node *u = (Node*) malloc(sizeof(Node)); 
    if (u != NULL) 
    { 
        strcpy(u->name, ch); 
        u->r = u->l = NULL; 
        u->cnt = 1; 
        sum++; 
    } 
    return u; 

 
Node* addnd(Node *nd, char *ch) 

    if (nd == NULL) 
        nd = newnd(ch); 
    else 
    { 
        int cmp = strcmp(nd->name, ch); 
        if (cmp == 0) 
        { 
            nd->cnt++; 
            sum++; 
        } 
        else if (cmp > 0) 
            nd->r = addnd(nd->r, ch); 
        else 
            nd->l = addnd(nd->l, ch); 
    } 
    return nd; 

 
void Inorder(Node* root) 

    if (root != NULL) 
    { 
        Inorder(root->r); 
        printf("%s %.4f\n", root->name, 100*(double)root->cnt/(double)sum); 
        Inorder(root->l); 
    } 

 
int main() 

    char ch[MAXN]; 
    Node* root = NULL; 
    while (gets(ch) != NULL) 
        root = addnd(root, ch); 
    Inorder(root); 
    return 0; 

#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAXN 40

typedef struct TNode{
 char name[MAXN];
 struct TNode *l, *r;
 int cnt;
}Node;
int sum = 0;

Node* newnd(char *ch)
{
 Node *u = (Node*) malloc(sizeof(Node));
 if (u != NULL)
 {
  strcpy(u->name, ch);
  u->r = u->l = NULL;
  u->cnt = 1;
  sum++;
 }
 return u;
}

Node* addnd(Node *nd, char *ch)
{
 if (nd == NULL)
  nd = newnd(ch);
 else
 {
  int cmp = strcmp(nd->name, ch);
  if (cmp == 0)
  {
   nd->cnt++;
   sum++;
  }
  else if (cmp > 0)
   nd->r = addnd(nd->r, ch);
  else
   nd->l = addnd(nd->l, ch);
 }
 return nd;
}

void Inorder(Node* root)
{
 if (root != NULL)
 {
  Inorder(root->r);
  printf("%s %.4f\n", root->name, 100*(double)root->cnt/(double)sum);
  Inorder(root->l);
 }
}

int main()
{
 char ch[MAXN];
 Node* root = NULL;
 while (gets(ch) != NULL)
  root = addnd(root, ch);
 Inorder(root);
 return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved