程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1391:Number Steps

HDU1391:Number Steps

編輯:C++入門知識

Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

 

 

\



 

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

 


Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

 


Output
For each point in the input, write the number written at that point or write No Number if there is none.

 


Sample Input
3
4 2
6 6
3 4


Sample Output
6
12
No Number

 

嘛~

昨晚快睡前沒想通,今天看一下就看出規律了=  =

 

 

[cpp]
#include <stdio.h>  
 
int main() 

    int t,a,b; 
    scanf("%d",&t); 
    while(t--) 
    { 
        scanf("%d%d",&a,&b); 
        if(a == 0 && b == 0) 
        { 
            printf("0\n"); 
            continue; 
        } 
        if(a!=b && a!=b+2) 
        { 
            printf("No Number\n"); 
            continue; 
        } 
        if(a%2) 
        { 
            printf("%d\n",a+b-1); 
        } 
        else 
        { 
            printf("%d\n",a+b); 
        } 
    } 
 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved