程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU3496:Watch The Movie(二維01背包)

HDU3496:Watch The Movie(二維01背包)

編輯:C++入門知識

Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.

 


Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

 


Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

 


Sample Input
1
3 2 10
11 100
1 2
9 1


Sample Output
3

 

題意:給出朵朵想買的碟子數,店子能賣的碟子數,祖父允許能看的時間長度

然後各處所有朵朵想買的碟子的時間長度與價值,求出能得到的最大價值

思路:因為有碟子數和時間的兩個限制條件,所以要開二維背包

殘念,因為一開始數組開小了而WA了= =

然後還是WA,看別人的博客還發現價值居然可能是負數!

再修改後終於過了

 

[cpp]
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std; 
 
const int MAX = 999999; 
int val[111],time[111],dp[111][1111]; 
int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        int n,m,l; 
        scanf("%d%d%d",&n,&m,&l); 
        int i,j,k; 
        for(i = 0; i<n; i++) 
            scanf("%d%d",&time[i],&val[i]); 
        for(i = 0; i<=m; i++) 
        { 
            for(j = 0; j<=l; j++) 
            { 
                if(i==0) 
                    dp[i][j] = 0; 
                else 
                    dp[i][j] = -MAX;//價值可能為負數  
            } 
        } 
        for(i = 0; i<n; i++)//狀態轉移  
        { 
            for(j = m; j>=1; j--) 
            { 
                for(k = l; k>=time[i]; k--) 
                { 
                    dp[j][k] = max(dp[j][k],dp[j-1][k-time[i]]+val[i]); 
                } 
            } 
        } 
        if(dp[m][l]<0) 
            dp[m][l] = 0; 
        printf("%d\n",dp[m][l]); 
    } 
 
    return 0; 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int MAX = 999999;
int val[111],time[111],dp[111][1111];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,l;
        scanf("%d%d%d",&n,&m,&l);
        int i,j,k;
        for(i = 0; i<n; i++)
            scanf("%d%d",&time[i],&val[i]);
        for(i = 0; i<=m; i++)
        {
            for(j = 0; j<=l; j++)
            {
                if(i==0)
                    dp[i][j] = 0;
                else
                    dp[i][j] = -MAX;//價值可能為負數
            }
        }
        for(i = 0; i<n; i++)//狀態轉移
        {
            for(j = m; j>=1; j--)
            {
                for(k = l; k>=time[i]; k--)
                {
                    dp[j][k] = max(dp[j][k],dp[j-1][k-time[i]]+val[i]);
                }
            }
        }
        if(dp[m][l]<0)
            dp[m][l] = 0;
        printf("%d\n",dp[m][l]);
    }

    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved