程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 2594 kmp水題 求s1的前綴和s2的後綴重復度的最大值

hdu 2594 kmp水題 求s1的前綴和s2的後綴重復度的最大值

編輯:C++入門知識

Simpsons’ Hidden Talents
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1588    Accepted Submission(s): 587

 

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 


Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 


Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 


Sample Input
clinton
homer
riemann
marjorie


Sample Output
0
rie 3


Source
HDU 2010-05 Programming Contest
 


Recommend
lcy
 

題意:  輸入 s1 s2  問s1的後綴 以及s2的前綴中 相同的字符最多有多少個  是什麼
 
 
思路:  kmp
 
[cpp]
#include<stdio.h>  
#include<string.h>  
char s1[51111],s2[51111]; 
int next[51111]; 
int d1,d2; 
void getnext() 

    int i=1,j=0; 
    next[1]=0; 
    while(i<=d1) 
    { 
        if(j==0||s1[i]==s1[j]) {i++;j++;next[i]=j;} 
        else j=next[j]; 
    } 

int kmp() 

    int i,j; 
    i=1;j=1; 
    while(i<=d2) 
    { 
        if(j==0||s2[i]==s1[j]) {i++;j++;} 
        //不用擔心這裡j會超出其最大長度d2 因為當j==d2+1的時候 就會進入j=next[j]返回前面去了  
        //因為s1[d2+1]是沒有值的不會等於對應位置的s2中的值  會返回到前面去  
        else j=next[j]; 
    } 
    return j-1; 

int main() 

    int k; 
    while(scanf("%s",s1+1)!=EOF) 
    { 
        scanf("%s",s2+1); 
        d1=strlen(s1+1); 
        d2=strlen(s2+1);//s2做主串  
        getnext(); 
        k=kmp(); 
        if(k==0) printf("0\n"); 
        else 
        printf("%s %d\n",s2+1+d2-k,k); 
    } 
    return 0; 

#include<stdio.h>
#include<string.h>
char s1[51111],s2[51111];
int next[51111];
int d1,d2;
void getnext()
{
 int i=1,j=0;
 next[1]=0;
 while(i<=d1)
 {
  if(j==0||s1[i]==s1[j]) {i++;j++;next[i]=j;}
  else j=next[j];
 }
}
int kmp()
{
 int i,j;
 i=1;j=1;
 while(i<=d2)
 {
  if(j==0||s2[i]==s1[j]) {i++;j++;}
  //不用擔心這裡j會超出其最大長度d2 因為當j==d2+1的時候 就會進入j=next[j]返回前面去了
  //因為s1[d2+1]是沒有值的不會等於對應位置的s2中的值  會返回到前面去
  else j=next[j];
 }
 return j-1;
}
int main()
{
 int k;
    while(scanf("%s",s1+1)!=EOF)
 {
  scanf("%s",s2+1);
  d1=strlen(s1+1);
  d2=strlen(s2+1);//s2做主串
  getnext();
  k=kmp();
  if(k==0) printf("0\n");
  else
  printf("%s %d\n",s2+1+d2-k,k);
 }
 return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved