程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj2488 &

poj2488 &

編輯:C++入門知識

A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24840   Accepted: 8412

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 Source

簡單的深搜,不多說,直接上代碼!

 #include<iostream> 
#include<stdio.h> 
#include<cstring> 
using namespace std; 
int pathlow[30],pathdown[30],visit[30][30]; 
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}},n,m;//這裡注意是字典序最小 
bool dfs(int low,int down,int num) 
{ 
    int i,x,y; 
    if(num==n*m) 
    { 
     
        for(i=0;i<n*m;i++) 
        { 
         
            printf("%c%d",'A'+pathdown[i],pathlow[i]+1); 
        } 
        return true; 
    } 
 
    for(i=0;i<8;i++) 
    { 
        x=low+dir[i][0]; 
        y=down+dir[i][1]; 
        pathlow[num]=x; 
        pathdown[num]=y; 
        if(x>=0&&x<n&&y>=0&&y<m&&(!visit[x][y])) 
        { 
         
            visit[x][y]=1; 
            if(dfs(x,y,num+1)) 
            { 
             
                return true; 
            } 
            else 
            { 
             
                visit[x][y]=0;//這裡要注意,一定要重新標記為0 
            } 
        } 
 
    } 
    return false; 
 
} 
int main () 
{ 
    int t,i; 
    while(scanf("%d",&t)!=EOF) 
    { 
     
        for(i=1;i<=t;i++) 
        { 
            printf("Scenario #%d:\n",i); 
            scanf("%d%d",&n,&m); 
            memset(visit,0,sizeof(visit)); 
            visit[0][0]=1; 
            pathlow[0]=0; 
            pathdown[0]=0; 
            if(!dfs(0,0,1)) 
            { 
             
                printf("impossible"); 
            } 
            printf("\n\n"); 
 
 
        } 
    } 
 
    return 0; 
} 

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int pathlow[30],pathdown[30],visit[30][30];
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}},n,m;//這裡注意是字典序最小
bool dfs(int low,int down,int num)
{
 int i,x,y;
 if(num==n*m)
 {
 
  for(i=0;i<n*m;i++)
  {
  
   printf("%c%d",'A'+pathdown[i],pathlow[i]+1);
  }
  return true;
 }

 for(i=0;i<8;i++)
 {
  x=low+dir[i][0];
  y=down+dir[i][1];
  pathlow[num]=x;
  pathdown[num]=y;
  if(x>=0&&x<n&&y>=0&&y<m&&(!visit[x][y]))
  {
  
   visit[x][y]=1;
   if(dfs(x,y,num+1))
   {
   
    return true;
   }
   else
   {
   
    visit[x][y]=0;//這裡要注意,一定要重新標記為0
   }
  }

 }
 return false;

}
int main ()
{
 int t,i;
 while(scanf("%d",&t)!=EOF)
 {
 
  for(i=1;i<=t;i++)
  {
   printf("Scenario #%d:\n",i);
   scanf("%d%d",&n,&m);
   memset(visit,0,sizeof(visit));
   visit[0][0]=1;
   pathlow[0]=0;
   pathdown[0]=0;
   if(!dfs(0,0,1))
   {
   
    printf("impossible");
   }
   printf("\n\n");


  }
 }

 return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved