程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj1050 To the Max 最大子矩陣

poj1050 To the Max 最大子矩陣

編輯:C++入門知識

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2Sample Output

15

最大子矩陣,首先一行數列很簡單求最大的子和,我們要把矩陣轉化成一行數列,就是從上向下在輸入的時候取和,map[i][j]表示在J列從上向下的數和,這樣就把一列轉化成了一個點,再用雙重,循環,任意i行j列開始的一排數的最大和,就是最終的最大和

 

#include <iostream> 
#include <stdio.h> 
using namespace std; 
int map[105][105]; 
int main() 
{ 
    int n,i,j,k,sum,x,max; 
    while(scanf("%d",&n)!=EOF) 
    { 
        for(i=0;i<n;i++) 
            for(j=0;j<n;j++) 
            { 
                scanf("%d",&x); 
                map[i][j]=map[i-1][j]+x; 
            } 
            max=-0x4f4f4f4f; 
        for(i=0;i<n;i++) 
            for(j=i;j<n;j++) 
            { 
                sum=0; 
                for(k=0;k<n;k++) 
                { 
                    sum+=map[j][k]-map[i][k]; 
                    if(sum<0) 
//小於0就相當於不用取了,直接去掉 

#include <iostream>
#include <stdio.h>
using namespace std;
int map[105][105];
int main()
{
    int n,i,j,k,sum,x,max;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
            {
                scanf("%d",&x);
                map[i][j]=map[i-1][j]+x;
            }
            max=-0x4f4f4f4f;
        for(i=0;i<n;i++)
            for(j=i;j<n;j++)
            {
                sum=0;
                for(k=0;k<n;k++)
                {
                    sum+=map[j][k]-map[i][k];
                    if(sum<0)
//小於0就相當於不用取了,直接去掉

             sum=0;
                    if(sum>max)
                        max=sum;


                }
            }
            printf("%d\n",max);
    }

    return 0;
}

                        sum=0;
                    if(sum>max)
                        max=sum;


                }
            }
            printf("%d\n",max);
    }

    return 0;
}



 

   

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved