程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 490 Rotating Sentences

UVA 490 Rotating Sentences

編輯:C++入門知識

Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.


Input and Output
As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)


The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.


Sample Input

Rene Decartes once said,
"I think, therefore I am."
Sample Output

"R
Ie
 n
te
h
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"     這是一道處理字符串的題目。將輸入的字符串順時針旋轉90度以後輸出。和矩陣的旋轉差不多。


#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,len,maxlen,k;
    char s[105][105];
    i=0;
    maxlen=0;
    memset(s,0,sizeof(s)); /*初始化*/
    while(gets(s[i])!=NULL)
    {
        len=strlen(s[i]);
        if(len>maxlen)  /*求最長的字符串長度*/
          maxlen=len;
		i++;
    }
    for(j=0;j<maxlen;j++)
    {
       for(k=i-1;k>=0;k--)
       {
           if(s[k][j]==0)
             printf(" ");
           else
             printf("%c",s[k][j]);
       }
       printf("\n");
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved