程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1200(來來回回串起來)

hdu1200(來來回回串起來)

編輯:C++入門知識

Problem Description Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down   t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x     Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.   Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as   toioynnkpheleaigshareconhtomesnlewx   Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.       Input There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.       Output Each input set should generate one line of output, giving the original plaintext message, with no spaces.       Sample Input 5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0   Sample Output theresnoplacelikehomeonasnowynightx thisistheeasyoneab

#include<stdio.h>  
#include<string.h>   
int main()  
{  
    int n,i,len,m,e,j;  
    char str[10000],ch[1000][25];  
    while(scanf("%d",&n)==1&&n)  
    {  
        getchar();  
        scanf("%s",str);  
        len=strlen(str);  
        m=len/n;//把str串分成m個小串   
        if(len%n)  
        m++;  
        for(i=0;i<m;i++)  
        if(i%2==0)//當能被2整除的就正向保存   
        {  
            e=0;  
             for(j=i*n;j<len&&j<(i+1)*n;j++)  
                ch[i][e++]=str[j];  
        }  
        else//否則就倒著保存   
        {  
            e=0;  
            for(j=(i+1)*n-1;j>=i*n;j--)  
            if(str[j]!='\0')  
            ch[i][e++]=str[j];  
        }  
        e=len%n;//注意,有的不能除盡,最後一個小串長度小於n   
        for(j=0;j<n;j++)  
        for(i=0;i<m;i++)  
        if(i==m-1)//最後一個小串輸出   
        {  
            if(j<e||e==0)  
            printf("%c",ch[i][j]);  
        }  
        else  
        printf("%c",ch[i][j]);  
  
        printf("\n");  
    }  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved