程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1671之字典樹

hdu1671之字典樹

編輯:C++入門知識

Phone List
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7014    Accepted Submission(s): 2409


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES

 

#include<iostream>   
#include<cstdio>   
#include<cstdlib>   
#include<cstring>   
#include<string>   
#include<queue>   
#include<algorithm>   
#include<map>   
#include<iomanip>   
#define INF 99999999   
using namespace std;  
  
const int MAX=10;  
char s[MAX+2];  
bool flag;  
  
struct TrieNode{  
    bool mark;  
    TrieNode *next[MAX];  
    TrieNode(){  
        mark=false;  
        memset(next,0,sizeof next);  
    }  
}root;  
  
void InsertNode(char *a){  
    int k=0;  
    TrieNode *p=&root;  
    while(a[k]){  
        if(!p->next[a[k]-'0'])p->next[a[k]-'0']=new TrieNode;  
        else if(a[k+1] == '\0')flag=false;  
        p=p->next[a[k++]-'0'];  
        if(p->mark)flag=false;  
    }  
    p->mark=true;  
}  
  
void Free(TrieNode *p){  
    for(int i=0;i<MAX;++i){  
        if(p->next[i])Free(p->next[i]);  
    }  
    delete p;  
}  
  
int main(){  
    int t,n;  
    cin>>t;  
    while(t--){  
        cin>>n;  
        flag=true;  
        while(n--){  
            cin>>s;  
            if(flag)InsertNode(s);  
        }  
        if(flag)cout<<"YES"<<endl;  
        else cout<<"NO"<<endl;  
        for(int i=0;i<MAX;++i){  
            if(root.next[i])Free(root.next[i]);  
            root.next[i]=NULL;  
        }  
    }  
    return 0;  
}  

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10;
char s[MAX+2];
bool flag;

struct TrieNode{
	bool mark;
	TrieNode *next[MAX];
	TrieNode(){
		mark=false;
		memset(next,0,sizeof next);
	}
}root;

void InsertNode(char *a){
	int k=0;
	TrieNode *p=&root;
	while(a[k]){
		if(!p->next[a[k]-'0'])p->next[a[k]-'0']=new TrieNode;
		else if(a[k+1] == '\0')flag=false;
		p=p->next[a[k++]-'0'];
		if(p->mark)flag=false;
	}
	p->mark=true;
}

void Free(TrieNode *p){
	for(int i=0;i<MAX;++i){
		if(p->next[i])Free(p->next[i]);
	}
	delete p;
}

int main(){
	int t,n;
	cin>>t;
	while(t--){
		cin>>n;
		flag=true;
		while(n--){
			cin>>s;
			if(flag)InsertNode(s);
		}
		if(flag)cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
		for(int i=0;i<MAX;++i){
			if(root.next[i])Free(root.next[i]);
			root.next[i]=NULL;
		}
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved