程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu3415 Max Sum of Max-K-sub-sequence(單調隊列求n個數中和的最大值)

hdu3415 Max Sum of Max-K-sub-sequence(單調隊列求n個數中和的最大值)

編輯:C++入門知識

Max Sum of Max-K-sub-sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4836    Accepted Submission(s): 1765


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input
4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output
7 1 3
7 1 3
7 6 2
-1 1 1
題意:在組成環的n個數中求出不超過m個連續的數相加之和最大時的最大值、起始位置和終止位置(如果大於n則要減去n)
這個題我覺得還是有必要做一做的,雖然跟以前做的那個單調隊列題有點像,可是這個求和的我還是第一次做

#include<stdio.h>   
int a[100005],sum[200005],q[200005];  
int main()  
{  
    int t,n,m,i,j,maxx,e,s,first,last;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d%d",&n,&m);  
        sum[0]=0;  
        for(i=1;i<=n;i++)  
        {  
            scanf("%d",&a[i]);  
            sum[i]=sum[i-1]+a[i];  
        }  
        for(;i<=n+m;i++)  
            sum[i]=sum[i-1]+a[i-n];//向後延伸m,這樣就可以達到循環的效果   
        first=last=0;  
        q[last++]=0;//這要注意,WA好多次了,還是對單調隊列理解的不夠   
        maxx=a[1];  
        e=s=1;  
        for(i=1;i<=n+m;i++)  
        {  
            while(first<last&&sum[q[last-1]]>sum[i-1])//找最小值?因為我們看的是sum[i]-sum[q[first]],而sum[i]是定值   
                //所以要使這一項最大就必須使sum[q[first]]在m的范圍內最小   
            {  
                last--;  
            }  
            q[last++]=i-1;//記錄的也是i-1   
            while(first<last&&q[first]<i-m)//超出范圍的去掉   
                first++;  
            if(maxx<sum[i]-sum[q[first]])  
            {  
                s=q[first]+1;//,我們當時記錄的是i-1,這裡要算起始點那就要加1   
                e=i;//終止點   
                maxx=sum[i]-sum[q[first]];//最大值   
            }  
        }  
        if(s>n)//這兩句話千萬別掉了   
            s-=n;  
        if(e>n)  
            e-=n;  
        printf("%d %d %d\n",maxx,s,e);  
    }  
    return 0;  
}  

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved