程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1963 && POJ2063:Investment(完全背包)

HDU1963 && POJ2063:Investment(完全背包)

編輯:C++入門知識

Problem Description
John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.

John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:
Value Annual interest
4000   400
3000   250

With a capital of $10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

 


Input
The first line contains a single positive integer N which is the number of test cases. The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

 


Output
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.
 


Sample Input
1
10000 4
2
4000 400
3000 250


Sample Output
14050

 

題意:給出初始資金,還有年數,然後給出每個物品的購買價格與每年獲得的利益,要求在給出的年份後所能得到的最大本利之和。

思路:因為每種物品可以多次購買,可以看做是完全背包的題目,但是要注意的是,由於本金可能會很大,所以我們要對背包的大小進行壓縮,值得注意的是,題目已經說了本金與物品的購買價格都是1000的倍數,所以我們可以將他們都除以1000來進行壓縮,然後就是一道完全背包模板題了。

 

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int v,w;
}a[20];

int dp[100000];

int main()
{
    int t,n,i,j,k,val,y;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&val,&y);
        scanf("%d",&n);
        for(i = 1;i<=n;i++)
        {
            scanf("%d%d",&a[i].v,&a[i].w);
            a[i].v/=1000;//進行壓縮
        }
        for(i = 1;i<=y;i++)
        {
            int s = val/1000;//每年本金都是上一年本金與利息之和
            memset(dp,0,sizeof(dp));//每年都要重新存利息
            for(j = 1;j<=n;j++)//完全背包
            {
                for(k = a[j].v;k<=s;k++)
                {
                    dp[k]=max(dp[k],dp[k-a[j].v]+a[j].w);
                }
            }
            val+=dp[s];//每年的最大本利和
        }
        printf("%d\n",val);
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved