程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1059 && POJ1014 :Dividing(多重背包)

HDU1059 && POJ1014 :Dividing(多重背包)

編輯:C++入門知識

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 


Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 


Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

 


Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0


Sample Output
Collection #1:
Can't be divided.

Collection #2:
Can be divided.

 

題意:一共有6種物品,價值分別是1,2,3,4,5,6,給出每種物品的數目,判斷師傅能夠平分

思路:典型的多重背包,防止超時要進行一些必要的剪枝和二進制優化

 

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

int dp[100000];

int main()
{
    int a[11],sum,v,i,j,k,cnt,cas = 1;
    while(~scanf("%d",&a[1]))
    {
        sum = a[1];
        for(i = 2;i<=6;i++)
        {
            scanf("%d",&a[i]);
            sum+=i*a[i];
        }
        if(!sum)
        break;
        printf("Collection #%d:\n",cas++);
        if(sum%2)//總和為奇數,必定不能平分
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        v = sum/2;
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for(i = 1;i<=6;i++)
        {
            if(!a[i])
            continue;
            for(j = 1;j<=a[i];j*=2)//二進制優化
            {
                cnt = j*i;
                for(k = v;k>=cnt;k--)
                {
                    if(dp[k-cnt])//必須前面的能夠放入背包,現在的才能放入背包
                    dp[k] = 1;
                }
                a[i]-=j;
            }
            cnt = a[i]*i;//剩下的
            if(cnt)
            {
                for(k = v;k>=cnt;k--)
                {
                    if(dp[k-cnt])
                    dp[k] = 1;
                }
            }
        }
        if(dp[v])
        printf("Can be divided.\n\n");
        else
        printf("Can't be divided.\n\n");
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved