程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1686

hdu1686

編輯:C++入門知識

題目意思:找到上串在下串中有多少個


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 


Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 


Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

#include<stdio.h>   
#include<string.h>   
  
int next[10005],lenw,lent;  
char W[10005],T[1000005];  
  
void set_next()  
{  
    int i=0,j=-1;  
    next[0]=-1;  
    lenw=strlen(W);  
    while(i<lenw)  
    {  
        if(j==-1||W[i]==W[j])  
        {  
            i++;j++;  
            next[i]=j;  
        }  
        else  
        j=next[j];  
    }  
}  
int KMP()  
{  
    int k=0,i=0,j=0;  
    lent=strlen(T);  
    while(i<lent)  
    {  
        if(T[i]==W[j]||j==-1)  
        {  
            i++;j++;  
        }  
        else  
        j=next[j];  
        if(j==lenw)  
        {  
            k++; j=next[j];//表示W的第j個以前都與T的從i-next[j]到第i-1這段已經匹好了   
        }                   //next[j]的值是在W[j]前面的串中最長前綴和最長後綴相等,那麼   
                          //當前的匹配成功,就說明W的第j個以前都與T的從i-next[j]到第i-1這段也已經匹配好了   
    }  
    return k;  
}  
int main()  
{  
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        getchar();  
        scanf("%s %s",W,T);  
        set_next();  
            printf("%d\n",KMP());  
    }  
}  

#include<stdio.h>
#include<string.h>

int next[10005],lenw,lent;
char W[10005],T[1000005];

void set_next()
{
    int i=0,j=-1;
    next[0]=-1;
    lenw=strlen(W);
    while(i<lenw)
    {
        if(j==-1||W[i]==W[j])
        {
            i++;j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int KMP()
{
    int k=0,i=0,j=0;
    lent=strlen(T);
    while(i<lent)
    {
        if(T[i]==W[j]||j==-1)
        {
            i++;j++;
        }
        else
        j=next[j];
        if(j==lenw)
        {
            k++; j=next[j];//表示W的第j個以前都與T的從i-next[j]到第i-1這段已經匹好了
        }                   //next[j]的值是在W[j]前面的串中最長前綴和最長後綴相等,那麼
                          //當前的匹配成功,就說明W的第j個以前都與T的從i-next[j]到第i-1這段也已經匹配好了
    }
    return k;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        getchar();
        scanf("%s %s",W,T);
        set_next();
            printf("%d\n",KMP());
    }
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved