程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1072 Nightmare (bfs+貪心)

hdu 1072 Nightmare (bfs+貪心)

編輯:C++入門知識

Nightmare
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5475    Accepted Submission(s): 2725

 

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

Sample Input
3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1

Sample Output
4
-1
13

Author
Ignatius.L
 
題意:一個迷宮,起始炸彈引爆時間給定為6。2表示起點,3表示終點。1表示可以走,0表示不能走。4表示炸彈引爆時間重新置為6。一個人背著炸彈從起點出發。問他是否在
          炸彈爆炸前走出迷宮。如果可以,輸出他所需要的最短時間,如果不行,輸出-1。
          規則:1、如果剛好走到3,炸彈引爆時間變為0,則算走不出迷宮。
                     2、如果剛好走到4,准備reset引爆時間。但是走到該點時引爆時間剛好變為0,則不能重新設置。
                     3、每一個4都可以走多次,只要他需要。
 
分析:這個題有回走的情況,但是只要滿足每次回走,到這點剩下的時間比上一次走到這剩下的時間長就可以了(貪心)。
           另外就是到達4和3時剩下的時間一定要>=1。
 


#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

int maps[10][10];
struct node
{
    int x,y;
    int steps;    //走的步數
    int ltime;    //炸彈引爆時間還剩多少
}start;
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};
int pass[10][10];     //記錄上次到達這點炸彈引爆還剩多少時間
int r,c;

bool cango(node &a)
{
    if(a.x>=0&&a.x<r&&a.y>=0&&a.y<c&&maps[a.x][a.y]!=0)
        return true;
    else return false;
}

int bfs()
{
    memset(pass,0,sizeof(pass));
    queue<node> q;
    while(!q.empty())
        q.pop();
    q.push(start);
    node cur,next;
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next.x=cur.x+dx[i];
            next.y=cur.y+dy[i];
            if(maps[next.x][next.y]==3&&cur.ltime<=1)
                continue;
            if(maps[next.x][next.y]==4&&cur.ltime<=1)
                continue;
            if(maps[next.x][next.y]==3)
                return cur.steps+1;
            if(maps[next.x][next.y]==4)
                next.ltime=6;
            else if(maps[next.x][next.y]==1)
                next.ltime=cur.ltime-1;
            if(cango(next)&&next.ltime>pass[next.x][next.y])
            {
                pass[next.x][next.y]=next.ltime;
                next.steps=cur.steps+1;
                q.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    int i,j,k,n;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&r,&c);
        for(j=0;j<r;j++)
        {
            for(k=0;k<c;k++)
            {
                scanf("%d",&maps[j][k]);
                if(maps[j][k]==2)
                {
                    start.x=j;
                    start.y=k;
                    start.steps=0;
                    start.ltime=6;
                    maps[i][j]=0;
                }
            }
        }
        int flag=bfs();
        printf("%d\n",flag);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved