程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu2660 Accepted Necklace (DFS)

hdu2660 Accepted Necklace (DFS)

編輯:C++入門知識

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

 

Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

 

Output
For each case, output the highest possible value of the necklace.


Sample Input
1
2 1
1 1
1 1
3

Sample Output
1
題目意思:求出K個寶石最大價值總和,但重量不能超過W;


#include<stdio.h>   struct ston  {      int sa,sw;  };  struct ston s[25],tem;  int su,N,K,W;  void DFS(int i,int suma, int w,int k)  {      int j;      if(su<suma)//比較總價值           su=suma;      if(k==K)//寶石個數不能超過K個       return ;      for(j=i+1;j<=N;j++)      if(s[j].sw+w<=W&&k+1<=K)      DFS(j,s[j].sa+suma,s[j].sw+w,k+1);  }  int main()  {      int t,i,j,e,sum;      scanf("%d",&t);      while(t--)      {          scanf("%d%d",&N,&K);          for(i=1;i<=N;i++)          scanf("%d%d",&s[i].sa,&s[i].sw);          scanf("%d",&W);            for(i=1;i<=N;i++)//先按價值從大到小排序           {              e=i;              for(j=i+1;j<=N;j++)              if(s[e].sa<s[j].sa)              e=j;              tem=s[i];s[i]=s[e];s[e]=tem;          }          sum=0;          for(i=1;i<=N;i++)//看以那個開頭總價值最大           if(s[i].sw<=W&&K>0)          {              su=s[i].sa;              DFS(i,s[i].sa,s[i].sw,1);              if(su>sum)              sum=su;          }          printf("%d\n",sum);      }  }  #include<stdio.h>
struct ston
{
    int sa,sw;
};
struct ston s[25],tem;
int su,N,K,W;
void DFS(int i,int suma, int w,int k)
{
    int j;
    if(su<suma)//比較總價值
        su=suma;
    if(k==K)//寶石個數不能超過K個
    return ;
    for(j=i+1;j<=N;j++)
    if(s[j].sw+w<=W&&k+1<=K)
    DFS(j,s[j].sa+suma,s[j].sw+w,k+1);
}
int main()
{
    int t,i,j,e,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&N,&K);
        for(i=1;i<=N;i++)
        scanf("%d%d",&s[i].sa,&s[i].sw);
        scanf("%d",&W);

        for(i=1;i<=N;i++)//先按價值從大到小排序
        {
            e=i;
            for(j=i+1;j<=N;j++)
            if(s[e].sa<s[j].sa)
            e=j;
            tem=s[i];s[i]=s[e];s[e]=tem;
        }
        sum=0;
        for(i=1;i<=N;i++)//看以那個開頭總價值最大
        if(s[i].sw<=W&&K>0)
        {
            su=s[i].sa;
            DFS(i,s[i].sa,s[i].sw,1);
            if(su>sum)
            sum=su;
        }
        printf("%d\n",sum);
    }
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved