程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2052 Picture

HDU 2052 Picture

編輯:C++入門知識

Picture
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12879 Accepted Submission(s): 6698

 


Problem Description
Give you the width and height of the rectangle,darw it.


Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.


Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.


Sample Input
3 2

Sample Output
+---+
|   |
|   |
+---+

import java.io.*;
import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner sc = new Scanner(new BufferedInputStream(System.in));
		while (sc.hasNextInt()) {
			int n = sc.nextInt();
			int m = sc.nextInt();
			if(n==1&&m==0){
				printFirst(n);
				printFirst(n);
				System.out.println();
			}
			else{
				printFirst(n);
				printSecond(n, m);
				printFirst(n);
				System.out.println();
			}
		}
	}

	public static void printFirst(int n) {
		System.out.print("+");
		for (int i = 0; i < n; i++) {
			System.out.print("-");
		}
		System.out.print("+");
		System.out.println();
	}

	public static void printSecond(int n, int m) {
		for (int j = 0; j < m; j++) {
			System.out.print("|");
			for (int i = 0; i < n; i++) {
				System.out.print(" ");
			}
			System.out.print("|");
			System.out.println();
		}
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved