程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 2255 Tree Recovery

poj 2255 Tree Recovery

編輯:C++入門知識

Tree Recovery
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9658   Accepted: 6067


Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input

DBACEGF ABCDEFG
BCAD CBAD
Sample Output

ACBFGED
CDAB
Source

Ulm Local 1997

 

/*
大概意思:給你二叉樹的前序遍歷,和中序遍歷,求後續遍歷,和hdu上的1710差不多
只是這題是單個字符,可以用字符串直接截取
*/
import java.util.Scanner;
public class Main{//AC
	static String s;
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		while(input.hasNext()){
			String pre=input.next();
			String rin=input.next();
			Node node=BT(pre,rin);//建立根節點
			PO(node);
			System.out.println();
		}
	}
	private static void PO(Node node) {//後續遍歷
		if(node!=null){
			PO(node.lchild);
			PO(node.rchild);
			System.out.print(node.data);
		}
		
	}
	private static Node BT(String pre, String rin) {
		if(pre.length()<=0)
			return null;
			//保存根節點
		char gen=pre.charAt(0);
		Node gjd=new Node(gen);
			//以根節點為邊界,把中序序列分成左右兩個子樹的中序序列
		int index=rin.indexOf(gen);
		String lrin=rin.substring(0, index);
		String rrin=rin.substring(index+1,rin.length());
			//以中序序列的長度,把除了根節點的前序序列分成左右兩個子樹的前序序列
		String lpre=pre.substring(1,lrin.length()+1);
		String rpre=pre.substring(lrin.length()+1, pre.length());
			//遞歸繼續分解左右子樹
		gjd.lchild=BT(lpre,lrin);
		gjd.rchild=BT(rpre,rrin);
		return gjd;
	}
}
class Node{//聲明二叉樹
	char data;
	Node lchild;
	Node rchild;
	Node(char data){
		this.data=data;
		this.lchild=null;
		this.rchild=null;
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved