程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 2251 搜索

poj 2251 搜索

編輯:C++入門知識

Dungeon Master
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13923   Accepted: 5424

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!
Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output

Escaped in 11 minute(s).
Trapped!這道題最坑人的地方在於poj上將他分類為dfs,結果一寫就超時,其實寫最短路一般肯定是bfs,哎,經驗還是太淺了。這道題還有一個值得注意的地方就是這是個3維的迷宮,只需要加上上下兩個方向就行了,其他的就是簡單的bfs。這道題wa了半天,居然是我忘記把文件輸入輸出那句話給刪了,尼瑪!下面是代碼:

#include <cstring>   #include <iostream>   #define pan(a,b,c) (a<=b&&b<=c)   using namespace std;    int dir[6][3]={{0,0,-1},{0,0,1},{-1,0,0},{1,0,0},{0,-1,0},{0,1,0}};  char map[35][35][35];  int vis[35][35][35];  int t,m,n,flag;  struct node{       int x,y,z;       int num;  }que[30010];    void bfs(int sx,int sy,int sz){        int head=0;        int tail=1;        que[0].x=sx;        que[0].y=sy;        que[0].z=sz;        que[0].num=0;        vis[sx][sy][sz]=1;         flag=0;        int xx,yy,zz;        while(head<tail){             for(int i=0;i<6;i++){                 xx=que[head].x+dir[i][0];                 yy=que[head].y+dir[i][1];                 zz=que[head].z+dir[i][2];                 if(map[xx][yy][zz]=='E'){//搜到終點                      printf("Escaped in %d minute(s).\n",que[head].num+1);                     flag=1;                     break;                 }                 if(pan(1,xx,t)&&pan(1,yy,m)&&pan(1,zz,n)&&vis[xx][yy][zz]==0&&map[xx][yy][zz]=='.'){//如果在迷宮內,並且未走過                         que[tail].x=xx;                        que[tail].y=yy;                        que[tail].z=zz;                        que[tail].num=que[head].num+1;                        vis[xx][yy][zz]=1;                        tail++;                 }            }              if(flag)                 break;                 head++;//flag不為1,那就要在繼續往後走         }        if(!flag)            cout<<"Trapped!"<<endl;  }    int main(){       //freopen("input.txt","r",stdin);        //freopen("output.txt","w",stdout);        int i,j,k;       int sx,sy,sz;       while(scanf("%d%d%d",&t,&m,&n)!=EOF){             if(t==0&&m==0&&n==0) break;             for(i=1;i<=t;i++)                 for(j=1;j<=m;j++)                     for(k=1;k<=n;k++){                          cin>>map[i][j][k];                          if(map[i][j][k]=='S'){//找到起點                                 sx=i;                                sy=j;                                sz=k;                          }                     }                     memset(vis,0,sizeof(vis));                     bfs(sx,sy,sz);       }       return 0;  }  #include <cstdio>
#include <cstring>
#include <iostream>
#define pan(a,b,c) (a<=b&&b<=c)
using namespace std;

int dir[6][3]={{0,0,-1},{0,0,1},{-1,0,0},{1,0,0},{0,-1,0},{0,1,0}};
char map[35][35][35];
int vis[35][35][35];
int t,m,n,flag;
struct node{
     int x,y,z;
     int num;
}que[30010];

void bfs(int sx,int sy,int sz){
      int head=0;
      int tail=1;
      que[0].x=sx;
      que[0].y=sy;
      que[0].z=sz;
      que[0].num=0;
      vis[sx][sy][sz]=1;
       flag=0;
      int xx,yy,zz;
      while(head<tail){
           for(int i=0;i<6;i++){
               xx=que[head].x+dir[i][0];
               yy=que[head].y+dir[i][1];
               zz=que[head].z+dir[i][2];
               if(map[xx][yy][zz]=='E'){//搜到終點
                   printf("Escaped in %d minute(s).\n",que[head].num+1);
                   flag=1;
                   break;
               }
               if(pan(1,xx,t)&&pan(1,yy,m)&&pan(1,zz,n)&&vis[xx][yy][zz]==0&&map[xx][yy][zz]=='.'){//如果在迷宮內,並且未走過
                      que[tail].x=xx;
                      que[tail].y=yy;
                      que[tail].z=zz;
                      que[tail].num=que[head].num+1;
                      vis[xx][yy][zz]=1;
                      tail++;
               }
          }
            if(flag)
               break;
               head++;//flag不為1,那就要在繼續往後走
      }
      if(!flag)
          cout<<"Trapped!"<<endl;
}

int main(){
     //freopen("input.txt","r",stdin);
     //freopen("output.txt","w",stdout);
     int i,j,k;
     int sx,sy,sz;
     while(scanf("%d%d%d",&t,&m,&n)!=EOF){
           if(t==0&&m==0&&n==0) break;
           for(i=1;i<=t;i++)
               for(j=1;j<=m;j++)
                   for(k=1;k<=n;k++){
                        cin>>map[i][j][k];
                        if(map[i][j][k]=='S'){//找到起點
                              sx=i;
                              sy=j;
                              sz=k;
                        }
                   }
                   memset(vis,0,sizeof(vis));
                   bfs(sx,sy,sz);
     }
     return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved