程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 2109 Power of Cryptography(用double避開高精度)

poj 2109 Power of Cryptography(用double避開高精度)

編輯:C++入門知識

Power of Cryptography
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 16238   Accepted: 8195

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).
Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.
Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
Sample Input

2 16
3 27
7 4357186184021382204544Sample Output

4
3
1234Source

México and Central America 2004

 

題意:給一對數 n(1<=n<=200)和p(1<=p<=10^101),求k使k^n=p。

分析:1、很自然的,因為覺得數據很大,會去想高精度。然後加二分猜數。

                 然後不會高精度啊。。

           2、於是想到轉換數學運算:指對互化。用double存,但是double 精確位只有6—7。而沒有logx Y,只有先轉化為以e為底的對數。用lognP=logn/logP。用兩次函數,

                  精確度不能滿足要求。

           3、換思路:k^n=p,則p^(1/n)=k。且函數可以直接用pow(x,y)去求x^y。

收獲:鞏固了一下基礎。啟發了一下思維。

          類型             長度 (bit)            有效數字                    絕對值范圍
          float             32                      6~7                  10^(-37) ~ 10^38
          double          64                     15~16               10^(-307) ~10^308
          long double   128                   18~19                10^(-4931) ~ 10 ^ 4932

代碼:

 

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    double n,p;
    while(scanf("%lf%lf",&n,&p)!=EOF)
    {
        printf("%.0lf\n",pow(p,1/n));
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved