程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 2524 Ubiquitous Religions(並查集算法)

POJ 2524 Ubiquitous Religions(並查集算法)

編輯:C++入門知識

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 20547   Accepted: 10082

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output

Case 1: 1
Case 2: 7
 思路:並查集算法

import java.io.*;
import java.util.*;
/*
 * @author denghuilong 
 *  
 * 2013-8-10上午1:26:18
 *
*/
public class Main {
	public static int student[];
	public static boolean boo[];
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int number=1;
		while(sc.hasNext()){
			int num=0;;
			int n=sc.nextInt();
			int m=sc.nextInt();
			if(n==0&&m==0)
				System.exit(0);
			student=new int[n+1];
			for(int i=1;i<=n;i++){
				student[i]=i;
			}
			boo=new boolean[n+1];
			Arrays.fill(boo,true);
			
			for(int i=0;i<m;i++){
				int a=sc.nextInt();
				int b=sc.nextInt();
				union(a,b);
			}
			for(int i=1;i<=n;i++){
				if(student[i]==i){
					if(boo[i]){
						num++;
						boo[i]=false;
					}
				}
				else{
					
					if(boo[find(i)]){
						num++;
						boo[find(i)]=false;
					}
				}
			}
			System.out.println("Case "+number+++": "+num);
		}
	}
	public static void union(int a,int b){
		int pa=find(a);
		int pb=find(b);
		if(pa==pb)
			return;
		if(pa>pb){
			student[pb]=pa;
		}
		else
			student[pa]=pb;
	}
	public static int find(int a){
		int p=student[a];
		if(p==a)
			return p;
		return find(p);
	}
}import java.io.*;
import java.util.*;
/*
 * @author denghuilong 
 *  
 * 2013-8-10上午1:26:18
 *
*/
public class Main {
	public static int student[];
	public static boolean boo[];
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int number=1;
		while(sc.hasNext()){
			int num=0;;
			int n=sc.nextInt();
			int m=sc.nextInt();
			if(n==0&&m==0)
				System.exit(0);
			student=new int[n+1];
			for(int i=1;i<=n;i++){
				student[i]=i;
			}
			boo=new boolean[n+1];
			Arrays.fill(boo,true);
			
			for(int i=0;i<m;i++){
				int a=sc.nextInt();
				int b=sc.nextInt();
				union(a,b);
			}
			for(int i=1;i<=n;i++){
				if(student[i]==i){
					if(boo[i]){
						num++;
						boo[i]=false;
					}
				}
				else{
					
					if(boo[find(i)]){
						num++;
						boo[find(i)]=false;
					}
				}
			}
			System.out.println("Case "+number+++": "+num);
		}
	}
	public static void union(int a,int b){
		int pa=find(a);
		int pb=find(b);
		if(pa==pb)
			return;
		if(pa>pb){
			student[pb]=pa;
		}
		else
			student[pa]=pb;
	}
	public static int find(int a){
		int p=student[a];
		if(p==a)
			return p;
		return find(p);
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved