程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1520:Anniversary party(樹形DP)

HDU1520:Anniversary party(樹形DP)

編輯:C++入門知識

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 


Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
 


Output
Output should contain the maximal sum of guests' ratings.

 


Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0


Sample Output
5

 

但是,將POJ的代碼貼上去是WA,加上一個n為0退出的條件是TLE

然後我還發現,如果調用結構體內的函數用時109ms

如果用外在函數,同樣超時

看來調用結構體內的函數比較節省時間

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int child,father,brother,present,not_present;
    int max()//結構體內的函數調用時耗時少
    {
        return present>not_present?present:not_present;
    }
    void init()
    {
        child=father=brother=not_present=0;
    }
}tree[6005];

void dfs(int root)
{
    int son = tree[root].child;
    while(son)
    {
        dfs(son);
        tree[root].present+=tree[son].not_present;
        tree[root].not_present+=tree[son].max();
        son = tree[son].brother;
    }
}

int main()
{
    int n,i,j,k,l;
    while(~scanf("%d",&n)&&n)
    {
        for(i = 1;i<=n;i++)
        {
            scanf("%d",&tree[i].present);
            tree[i].init();
        }
        while(~scanf("%d%d",&l,&k),l+k)
        {
            tree[l].father = k;
            tree[l].brother = tree[k].child;
            tree[k].child = l;
        }
        for(i = 1;i<=n;i++)
        {
            if(!tree[i].father)
            {
                dfs(i);
                printf("%d\n",tree[i].max());
                break;
            }
        }
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved