程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> BNU Concentric Rings

BNU Concentric Rings

編輯:C++入門知識

 

There are several different concentric rings on the ground. Some of them may overlap. In Figure 1, there are 3 rings: blue, green and red. The red one is just above the green one. The problem is to remove minimum number of rings so that no two of the remaining overlap.

Figure 1Input The input consists of multiple test cases. Each test case starts with a positive integer N (<=10000) which represents the number of rings. The next N lines each line contains two positive integers which represents the inner radius and outer radius respectively.
Output For each test case, output the minimum number of rings to remove.
Sample Input: 3
1 2
3 6
4 5
Sample Output: 1


Source
CYJJ's Funny Contest #1, Killing in Seconds

 


這題和杭電上有個看電視的那個一樣,簡單貪心題,這個題首先輸入有n個環,接下來每行都是環的內半徑和外半徑,然後求滿足不能有重疊所需要刪除幾個環。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

struct Node
{
    int inner,outer;
}a[10010];

bool cmp(Node a, Node b)
{
    return a.outer < b.outer;
}

int main()
{
    int n,i,j,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum = 0;
        for(i = 0; i < n; i++)
        {
            scanf("%d%d",&a[i].inner,&a[i].outer);
        }
        sort(a,a+n,cmp);
        j = 0;
        for(i = 1; i < n; i++)
        {
            if(a[i].inner < a[j].outer)
            {
                sum++;
                a[i].inner = a[i].outer = 0;
            }
            else
            {
                j = i;
            }
        }
        printf("%d\n",sum);
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved