程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1251 Jungle Roads

POJ 1251 Jungle Roads

編輯:C++入門知識

Jungle Roads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17586   Accepted: 7937

Description

 

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.


Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0Sample Output

216
30題意:

有n個點,其中每個點與其它若干點相連。求最小生成樹

 


這是道裸題,主要要熟悉一下Prime 和 krusical 兩種算法

1. Prime 是每次選一個點進集合,然後找到集合內到集合外的最短路,把這條最短路的對應未進入集合的點加入集合。

2. Krusical 將所有路徑按照從小到大排序,然後每次選擇最短的路徑加入集合(要求是路徑兩個端點中最少有一個點沒有進入集合)。這裡要用到並查集

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main ()//prime
{
    int n,i,j;
    char ch;
    while(cin>>n)
    {
        int t,s,k,sum=0;
        int map[30][30]={0};
        int low[30]={0},visit[30]={0};
        if (n==0) break;
        for (i=0; i<n; i++)
            for (j=0; j<n; j++)
                map[i][j]=10000;
        for (i=0; i<n-1; i++)
        {
            cin>>ch>>t;
            while(t>0)
            {
                cin>>ch>>s;
                map[i][ch-'A']=map[ch-'A'][i]=s;
                t--;
            }
        }
        visit[0]=1;
        for (i=0; i<n; i++)
            low[i]=map[0][i];
        for (i=1; i<n; i++)
        {
            int min=10000;
            for (j=0; j<n; j++)
                if (!visit[j] && low[j]<min)
                {
                    min=low[j];
                    k=j;
                }
            sum+=low[k];
            visit[k]=1;
            for (j=0; j<n; j++)
                if (!visit[j] && low[j]>map[k][j])
                    low[j]=map[k][j];
        }
        cout<<sum<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved