程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ2282:The Counting Problem(數位DP)

POJ2282:The Counting Problem(數位DP)

編輯:C++入門知識

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be

1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.
Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.
Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.
Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0
Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247
 題意:求出區間內0~9的個數思路:dp[i][j],代表長度為i的數字裡面共有幾個j 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

__int64 dp[10][10];

__int64 pow(__int64 a,__int64 b)
{
    __int64 ans = 1,i;
    for(i = 1; i<=b; i++)
        ans*=a;
    return ans;
}

void set()
{
    memset(dp,0,sizeof(dp));
    for(__int64 i = 1; i<=9; i++)
    {
        for(__int64 j = 0; j<=9; j++)
            dp[i][j] = dp[i-1][j]*10+pow(10,i-1);
    }
}

__int64 solve(__int64 n,__int64 pos)
{
    __int64 s[15],len = 0,i,tem;
    while(n)
    {
        s[++len] = n%10;
        n/=10;
    }
    s[0] = 0;
    __int64 ans = 0,cnt = 0;
    for(i = len; i>=1; i--)
    {
        if(pos == 0 && i == len)//找出0的情況
        {
            ans+=dp[i-1][pos]*(s[i]-1);
            tem = pow(10,i-1)-1;
            ans+=solve(tem,0);
        }
        else//不為0,則後面的個數要進行s[i]次相加
            ans+=dp[i-1][pos]*s[i];
        ans+=cnt*pow(10,i-1)*s[i];//計算前面的與要求的數字相同的被運算了幾次
        if(pos)
        {
            if(s[i]>pos)
                ans+=pow(10,i-1);//s[i]>tmp,則s[i]==tmp時,要將刺猬相加pow(10,i-1)次
            if(s[i]==pos)
                cnt++;
        }
        else if(i!=len)
        {
            if(s[i]>pos)
                ans+=pow(10,i-1);
            if(s[i]==pos)
                cnt++;

        }
    }
    return ans+cnt;
}

int main()
{
    set();
    __int64 l,r,i;
    while(~scanf("%I64d%I64d",&l,&r),l+r)
    {
        if(l>r)
            swap(l,r);
        printf("%I64d",solve(r,0)-solve(l-1,0));
        for(i = 1; i<=9; i++)
            printf(" %I64d",solve(r,i)-solve(l-1,i));
        printf("\n");
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved